Web lists-archives.com

something wrong with audio




Sorry for the subject not-so-specific but I hope this message can start a first iteration to better focus my problem.

The problem in short: no sound card available to pulsaudio, while ALSA seems to correctly detect HDA Intel PCH.
To make the problem more puzzling, in the same laptop with an ubuntu live (with kernel 4.15) audio works correctly.

This means that the soundcard IS supported in some way (though I don't know the ubuntu way). Tried to test if the cause is kernel regression: installed kernel 4.15 (from debian snapshot), but the song remains the same (in this case the song is the sound of silence).

This drives me crazy.

I'm ready to perform any diagnostics/tests you could imagine to get my audio back.

Below I report the info on hardware and kernel.

Please help!!!

-- hardware: Lenovo Thinkpad X270;
-- soundcard (from lspci) 00:1f.3 Audio device: Intel Corporation Sunrise Point-LP HD Audio (rev 21)
-- debian_version: sid
-- kernel: 4.18.0-2-amd64
-- kernel modules ( lsmod | grep snd)
snd_hrtimer            16384  1
snd_seq_midi           16384  0
snd_seq_midi_event     16384  1 snd_seq_midi
snd_rawmidi            40960  1 snd_seq_midi
snd_seq                81920  3 snd_seq_midi,snd_seq_midi_event
snd_seq_device         16384  3 snd_seq,snd_seq_midi,snd_rawmidi
snd_hda_codec_hdmi     61440  1
snd_hda_codec_realtek   110592  1
snd_hda_codec_generic    86016  1 snd_hda_codec_realtek
snd_soc_skl           118784  0
snd_soc_skl_ipc        73728  1 snd_soc_skl
snd_soc_sst_ipc        16384  1 snd_soc_skl_ipc
snd_soc_sst_dsp        36864  1 snd_soc_skl_ipc
snd_hda_ext_core       28672  1 snd_soc_skl
snd_soc_acpi           16384  1 snd_soc_skl
snd_soc_core          253952  1 snd_soc_skl
snd_compress           24576  1 snd_soc_core
snd_hda_intel          45056  3
snd_hda_codec         151552  4 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec_realtek
snd_hda_core           94208  7 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_ext_core,snd_hda_codec,snd_hda_codec_realtek,snd_soc_skl
snd_hwdep              20480  1 snd_hda_codec
snd_pcm_oss            61440  0
snd_mixer_oss          28672  1 snd_pcm_oss
snd_pcm               118784  9 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_ext_core,snd_hda_codec,snd_pcm_oss,snd_soc_core,snd_soc_skl,snd_hda_core
snd_timer              36864  4 snd_seq,snd_hrtimer,snd_pcm
snd                    94208  21 snd_hda_codec_generic,snd_seq,snd_seq_device,snd_hda_codec_hdmi,snd_hwdep,snd_hda_intel,snd_hda_codec,snd_hda_codec_realtek,snd_timer,snd_compress,snd_pcm_oss,thinkpad_acpi,snd_soc_core,snd_pcm,snd_rawmidi,snd_mixer_oss
soundcore              16384  1 snd

alsamixer see teo sound cards:
-- default (pulseaudio)
-- HDA Intel PCH
for this second card (when selected with F6), alsamixer displays a list (relatively rich) of audio I/O controls

HOWEVER, pulsaudio only sees a (useless) dummy output, saying "no cards available for configuration" in the Configuration tab.