Web lists-archives.com

Re: More info - was [Re: Synaptic fails to fix broken packages]




On Friday, October 05, 2018 06:06:25 AM Reco wrote:
> On Fri, Oct 05, 2018 at 04:57:36AM -0500, Richard Owlett wrote:

> > Can someone point me to a discussion of why one would chose a particular
> > option?
> 
> Why do you need a discussion of that if you have apt-get(8)?
> 
> upgrade is used to install the newest versions of all packages currently
> installed on the system from the sources enumerated in
> /etc/apt/sources.list. Packages currently installed with new versions
> available are retrieved and upgraded; under no circumstances are
> currently installed packages removed, or packages not already installed
> retrieved and installed. New versions of currently installed packages
> that cannot be upgraded without changing the install status of another
> package will be left at their current version.
> 
> dist-upgrade in addition to performing the function of upgrade, also
> intelligently handles changing dependencies with new versions of
> packages.

I'm not the op, but I didn't quite get that (so I did try to read the relevant 
portions of apt-get (8), and here is my understanding.

As stated clearly, upgrade will not necessarily upgrade everything that could 
be upgraded, specifically if installing new dependencies would disable some 
other package.

dist-upgrade will attempt to handle those situations, but may end up disabling 
some packages.  dist-upgrade apparently has some mechanism to decide which 
packages are more important, and upgrade those while (possibly) disabling some 
packages that it deems less important.

(Maybe that mechanism is described elsewhere in apt-get (8).)

Is my understanding correct?

Can someone describe (or point to) a description of how dist-upgrade 
determines the more important app?  (Oh, I'm guessing it has to do with the 
whatever it is called label on each package, something like required, 
recommended, ... (I may be using the wrong words).  Supposed dist-upgrade has 
to choose between two packages that have the same label?