Web lists-archives.com

Re: Not finding openssl during a pkg build (mailsend)




On Mon, Oct 01, 2018 at 12:47:01PM -0400, Harry Putnam wrote:
> cat /etc/debian_version
> 9.4

> I do have openssl and libssl-dev installed;

In stretch, libssl-dev is the development package for OpenSSL version 1.1.
This is a relatively new version of OpenSSL, and it is not compatible with
version 1.0.

Most programs that use OpenSSL will be expecting to use the version 1.0 API.
I don't know your particular program, but it's a reasonable guess that
it wants the older version.

Try installing libssl1.0-dev (which will remove libssl-dev) and see if that
works.  You can switch back and forth as needed when compiling various
programs, but you can't have both installed at the same time.