Web lists-archives.com

Re: Bug#908349: firefox-esr: no sound after upgrading from 52.9 to 60.2




	Hi.

On Mon, Sep 10, 2018 at 09:59:03AM +0100, Brad Rogers wrote:
> On Sun, 9 Sep 2018 11:43:39 +0300
> Reco <recoverym4n@xxxxxxxxx> wrote:
> 
> Hello Reco,
> 
> >Moreover, apulse causes Firefox to crash since Firefox version 58, as
> 
> I've not been running apulse long, but so far, no crashes in Ff 62.

So upstream lies then. To quote apulse's README.md:

Firefox 58 (Nightly) tightened its sandbox a bit more. Now `ioctl()`
calls are forbidden too, but are used by ALSA libraries. That causes
sandbox violation with subsequent process termination. Exception can be
added by setting parameter `security.sandbox.content.syscall_whitelist`
in `about:config`. That field accepts a comma separated list of system
call numbers. Add there `16` for x86-64, or `54` for x86 or ARM.


> >apulse is a kludge, not a solution.
> 
> That's as may be (I don't have an opinion either way).

It's the usual. A compatibility wrapper can never exceed the original.
But - if it works for anyone - more power to them.

Reco