Web lists-archives.com

openvpn and new openssl 1.1.1~~pre9-1




Hi,

After upgrading to openssl 1.1.1~~pre9-1, I am not able to establish VPN
connections (eg.nordvpn, work, etc.)

Mon Sep  3 11:19:34 2018 us=634061 OpenSSL: error:1425F18C:SSL
routines:ssl_choose_client_version:version too low
Mon Sep  3 11:19:34 2018 us=634070 TLS_ERROR: BIO read
tls_read_plaintext error
Mon Sep  3 11:19:34 2018 us=634074 TLS Error: TLS object -> incoming
plaintext read error
Mon Sep  3 11:19:34 2018 us=634079 TLS Error: TLS handshake failed
Mon Sep  3 11:19:34 2018 us=634174 TCP/UDP: Closing socket
Mon Sep  3 11:19:34 2018 us=634201 SIGUSR1[soft,tls-error] received,
process restarting

When I downgrade the package to previous version everything works again.

# dpkg -i /var/cache/apt/archives/openssl_1.1.0h-4_amd64.deb


Is there any setting with the new SSL to allow older client version?

Thx.
Debian Sid