Web lists-archives.com

Re: anybody maintaining lxc and lxd in Debian?




On 7/10/18 12:36 PM, Jonathan Dowland wrote:
> On Fri, Jul 06, 2018 at 09:56:58AM +0200, Harald Dunkel wrote:
>> is anybody maintaining lxc in Debian? I have the impression that
>> it has been orphaned. And I don't dare to hope for #768073 anymore.
>
> Ah yes I'd forgotten about that (I was involved for a while). But
> looking at the current status it's not as bleak as I feared; the last
> dependency was finally finished in February.
>

I saw the updates in #768073. Good to know that it hasn't been forgotten.

How about LXC? In the meantime I built and tried Ubuntu's version 3.0.1
on Stretch. It builds fine. The package upgrade path was a little bit
rough, but it seems to work. Didn't try apparmor, though. Kernel was
4.16.12-1~bpo9+1.

One problem here: LXC 2.1 (not available in Debian) could be used to
migrate to the new config file format. 3.0.1 doesn't support the old
format anymore, i.e. running LXC 2.0 it is *mandatory* to adjust the
config files for 3.0.1 (using the provided lxc-update-config script).


Regards
Harri