Web lists-archives.com

Re: netboot images for Debian 9 seems is broken?




Hello,

On Mon, Jun 18, 2018 at 02:26:20PM +0100, Mike wrote:
> On Fri, Jun 15, 2018 at 01:43:50AM +0000, Andy Smith wrote:
> > On Thu, Jun 14, 2018 at 03:29:28PM -0400, mizuki wrote:
> > > "No kernel modules were found. This probably is due to a mismatch between
> > > the kernel used by this version of the installer and the kernel version in
> > > the archive.
> > 
> > In my experience, the above is correct. That is, I've experienced
> > this sort of thing 3 or 4 times and every time that has been the
> > reason for it.
> 
> Forgive me if this is a stupid question but what exactly does that mean
> ie what is "the archive"?  Presumably that means a mismatch between the
> linux kernel and the kernel modules in the initrd or am I very much
> mistaken?

Yes. When you PXE boot, the kernel and initramfs comes from the
netboot image that you downloaded in the past, but the archive will
be different after a point release which can result in the
installer's failure to load certain essential modules like
filesystems.

So in my experience every time there is a point release you need to
re-download the netboot images that you are serving over PXE as
well.

> Are the PXE installers known to be a little flaky?

I've got along with them okay as long as I remember to download a
new one after every point release.

I'm not 100% sure this is OP's problem (the Ubuntu reference is
alarming), but if I was OP I'd certainly try doing that first.

Cheers,
Andy

-- 
https://bitfolk.com/ -- No-nonsense VPS hosting