Web lists-archives.com

Debian 9.4 and Aspeed/AST2400





Hello,

We are having trouble getting Linux to function properly on SuperMicro hardware (X10SRI-F + E5-2620v4) which uses the AST2400 for VGA output. We have tried several "desktop" distributions: Ubuntu, Fedora, Xubuntu, Lubuntu, and Debian. As well as several versions of Ubuntu. We noticed the issue first starts with Ubuntu 16.04.2 and is still present in 18.04. In 16.04.1 and below the video is working fine. Debian is also using a newer kernel which has problems with this aspeed chip.  

Our issue is that the video output is very very slow at updating. Even the TTY framebuffer console can be slow at rendering. We open a window or click a menu and we can see each line of the display being drawn very slowly. Similarly, the login screens respond very slowly to keyboard input and mouse lags and jumps around.

We have narrowed the issue down to specifically to Linux Kernel version 4.9 and above. Running Kernel version 4.8 or lower has no video issues at all.

Is this a known issue? Is there a known fix? Maybe we need to roll back the BIOS?

There are two possible fixes we found, but they may just be covering up the issue rather than fixing it:

1) set the cpu frequency in Linux to the maximum speed, with "performance" governor. This helps, but doesn't completely solve the slow video rendering and tearing. Also, it is not permanent. 

2) Set the gpu/vga OPROM to "EFI" in the BIOS. This seems to fix the slow graphics issue on the desktop, but does not help with the slow rendering on the login screen.

From what we can tell, the "ast" video driver is being used. Moving the ast kernel module from one system do another doesn't do anything, but switching between 4.8 and 4.9 is where everything breaks. 

Best regards,
Ryan Capote
Team ABMX Servers