Web lists-archives.com

Re: A newer kernel for my genesi smartbook




On 2018-06-13 21:25 +0200, Robert Pommrich wrote:

> I am a still proud owner of a genesi smartbook.
>
> It is still running wheezy with a kernel in version 2.6.31 with Uboot as
> boot loader.
>
> Someone told me, that the hardware should be supported by now by a
> mainline kernel.

Unfortunately, it's not - not anymore, that is.  Support for the Efika
MX smartbook was added in Linux 2.6.39, and it should work with the
linux-image-mx5 kernel in Wheezy - FSVO work, because the GPU only works
to its potential with proprietary drivers, as on nearly all ARM-based
machines, and I am not sure about other drivers (sound, Wifi…)  either.

The bad news is that support for your machine got ripped out again in
Linux 3.7, as nobody added device tree support for it, and so the Jessie
kernel does not work with it, as mentioned in the release notes[1].

> I don't know how to find out, if the hardware is really supported, nor
> how to build a mainline kernel and integrate it with Uboot.

Install the linux-image-mx5 kernel and the flash-kernel package from
Wheezy, it should know what to do.  If the official Wheezy kernel works,
you can upgrade your userland to Jessie (and maybe to Stretch, but note
that systemd in Stretch officially requires Linux 3.12).  This would
give you a few extra years.

Good luck,
Sven


1. https://www.debian.org/releases/jessie/armhf/ch02s01.html.en