Web lists-archives.com

Re: backporting php7.2




	Hi.

On Wed, Jun 06, 2018 at 07:15:59PM +0200, Lucio wrote:
> I'm trying to backport php7.2 to Debian stretch.
> 
> $ apt-get build-dep php7.2
> 
> The following NEW packages will be installed:
> [...]  default-mysql-server galera-3 mariadb-server-10.1
> mariadb-server-core-10.1 [...]
> 
> Why does BUILDING php7.2 require a mariadb server running?

Every building process worthy of its title requires freshly built
software to pass certain tests.
In the case of php7.2 such tests include communicating with
MySQL/MariaDB database.

Debian PHP Maintainers cheated it BTW, enabling tests only for
i386/amd64. Speaks volumes about quality of those tests IMO.

Reco