Web lists-archives.com

Re: Debian 9 x64 wine32




On 06/05/2018 03:57 AM, --- wrote:
> What i did:
> 
> Starting off with: apt install wine32
> 
> Reading the messages, adding libwine:i386 and tried "apt install" again
> 
> Reading again etc. adding step by step all requested (not suggested)
> packages.
> 
> So all in all i entered:
> 
> apt install wine32 libwine:i386 libglu1-mesa:i386 libldap-2.4-2:i386
> libpulse0:i386 libgl1-mesa-glx:i386 libdbus-1-3:i386 libsystemd0:i386
> libdrm2:i386

Huh, is apt not able to resolve those dependencies? aptitude handled
them for me just fine... Or not. Been a while since I installed wine on
this system, and I might have done some manual dependency resolution
with aptitude, can't recall.

> WARNING: Following packages will be removed . . . .
>   bsdutils libsystemd0 (wegen bsdutils) init systemd-sysv (wegen init)
> sysvinit-utils
>   util-linux (wegen sysvinit-utils)

Anyways, the problem's here, none of these packages are supposed to be
removed when installing wine.

Looking at libsystemd0, it has a few "breaks" relations to other
versions of libsystemd0 (on my system, libsystemd0:i386 !=
232-25+deb9u3) and I'm assuming apt is trying to install one of those
"bad" versions. Since you've explicitly stated that you want to install
libsystemd0:i386, apt decided that removing libsystemd0:amd64 is the
only option.

Not exactly sure how to do this with apt, but when I've had similar
issues from time to time when installing wine on other systems, I just
resolved dependencies manually using aptitude. It can be a bit
burdensome, but should work once you select the proper versions of core
packages so that they do not conflict with existing system packages, and
then let aptitude do the rest of the resolution for you.

That's the reason I still use aptitude, sometimes I really need to
manually resolve dependencies in order to avoid pulling in those bad
packages.

Good luck!