Web lists-archives.com

Re: Intermittent blank screen – Stretch






On 02/06/18 08:11, floris wrote:
Mike schreef op 2018-06-01 01:27:
I have just installed Stretch and and randomly getting a 2 second (or
so) blank screen. I can go for quite some time without it happening,
or it can happen several times over a few minutes. I can dual boot
with Jessie and do not have the problem with that – so I think I can
rule out a hardware issue.

I have an Nvidia GTX1050 video card, HDMI output to a Samsung 49" TV,
4K video. There is no other type of input into the TV for me to be
able to test.

Here is what I have done
1. Installed Stretch (amd64) with XFCE
2. apt-get install firmware-linux nvidia-driver nvidia-settings nvidia-xconfig
3. run nvidia-xconfig
4. turned off screen blanking in power settings

I am quite happy to spend time troubleshooting, but don’t really know
where to start. The blanking happens too quickly for me to be able to
do anything at the time.

Does anyone have any thoughts?

Thanks

Mike

You can try the NVidia driver module from backports [1] and/or run journalctl -f in a terminal and wait for the blank screen.

[1] https://packages.debian.org/stretch-backports/nvidia-driver
---
Floris


Okay, now here is a weird thing.

I just unplugged a USB cable that was, in turn, connected to a microcontroller. My screen went blank. When I plugged in back in it went blank again. This happened about 4 times until I could plug and unplug without the blanking. I left it for 30-odd seconds and was able to do the same thing. It did not happen when I unplugged my computer keyboard, or my USB camera.

Does this give anyone any ideas?

Thanks.

Mike