Web lists-archives.com

Re: Installing Debian on a Minnowboard Turbot with installer on USB stick?




Well… I have some results.  Just not the kind I was expecting!  (see below)

On Jun 2, 2018, at 5:15 PM, Rick Thomas <rbthomas@xxxxxxxxx> wrote:

> I have a confession to make…
> 
> On Jun 2, 2018, at 6:09 AM, Thomas Schmitt <scdbackup@xxxxxxx> wrote:
> 
>> Rick Thomas reported that the boot process of
>> firmware-buster-DI-alpha2-amd64-DVD-1.iso
>> fails with
>> Incorrect CD-ROM detected
>> after it was re-partitioned to GPT.
> 
> On the advice of another comment in this thread, I didn’t use
>    firmware-buster-DI-alpha2-amd64-DVD-1.iso
> for those experiments.  Instead, I used
>    firmware-9.4.0-amd64-netinst.iso
> to avoid any possible alpha/testing anomalies.
> 
> I neglected to say that in my earlier report.  I’m sorry for any confusion it has caused!
> 
> 
> This afternoon, I plan to make a comprehensive set of tests: 
>   (a) “as-is” no messing with the partition tables at all; just dd directly to the USB stick.
>   (b) an automatically gdisk-built GPT table deleting partition 1 and leaving partition 2 unmodified except for setting as type EF00.
>   (c) an automatically gdisk-built GPT table based upon the original MBR table deleting partition 1 and leaving partition 2 unmodified except for setting as type EF00.
>   (d) a hand-built (using disk) GPT table with partition 1 having the same start/end as the partition 2 had in the original GPT table and type EF00, and no partition 2.
> 
> I plan to start with
>    debian-9.4.0-amd64-netinst.iso
> because it’s the smallest (to minimizing time spend dd-ing) and has the fewest non-fully-supported features to confuse issues.  In particular, this is not the firmware-9.4 I used above.
> 
> I’ll report back as soon as I have some results.
> 
> Thanks for all the help!
> Rick

“Curiouser and curiouser!” cried Alice.

When I tried part (a) — just a simple dd — with debian-9.4.0-amd64-netinst.iso, the minnowboard immediately recognized it as bootable and presented it as part of the EFI menu labeled “EFI USB Device”.  When I chose that option, it booted without incident and ran the installer.  When it came to the part where it looks for a CD, it easily found the USB stick (no intervention on my part required) and proceeded to read modules from it.  I let it go til it got to the partitioning phase.  I stopped it there.

So, I moved on to try the same thing (just part (a)) with “firmware-9.4.0-amd64-netinst.iso”.  With the same results — it gave me the EFI menu offering the USB stick. When I chose that, it proceeded to install, finding and reading the “CD” as usual.

So, I was beginning to wonder if I were going crazy.  In any case, I tried part (a) with “firmware-buster-DI-alpha2-amd64-DVD-1.iso”.  And guess what!  That worked too, just the same as the other two.

Conclusion:  Either I’m imagining things, or there’s something flakey about the USB ports on this device that sometimes causes a USB stick to NOT be recognized as a bootable device.

Thomas, If you would like to follow up on the inability of the installer to recognize itself as a suitable installation CD after the partition table has been modified, please let me know and I’ll be happy to help any way I can.

In any case, I apologize for all the noise.

Rick

PS: One other item that may shed light — the above experiments were performed using an 8GB Generic USB2.0 flash drive purchased thru NewEgg direct from a factory in China.  On the suspicion that there might be something strange about the USB ports on the minnowboard, tried it with a name-brand 16GB USB3.0 flash drive from Kingston DataTraveler.

The minnowboard has two USB ports.  The “upper” port is USB2.0 and is usually used for a keyboard/mouse combo.  The “lower” port is USB3.0 and recommended for attaching mass storage devices, such as the Debian installer.

When I plugged the USB3.0 DataTraveler into the lower (USB3.0) slot, it was NOT recognized as bootable.  So I swapped the plugs, plugging the keyboard/mouse into the lower (USB3.0) slot, and the DataTraveler into the upper (USB2.0) slot.  Guess what!  This time it WAS recognized as a bootable device!

So it appears that the minnowboard firmware (or USB hardware?) has trouble recognizing a USB3.0 device as bootable???  Something to take up with the Netgate minnowboard support folks, I guess.

Enjoy!