Web lists-archives.com

Trouble installing openedx on Debian9




Greetings,
    I am a student,according to me this is a Debian question so I have asked here.Please let me know if I have asked in the wrong place.
Just to learn, I am trying to install open edx on Debian and I faced this error.
 
The error is.

An exception occurred during task execution. To see the full traceback, use -vvv. The error was: apt.cache.FetchFailedException: E:The repository 'http://ppa.edx.org stretch Release' does not have a Release file.
fatal: [localhost]: FAILED! => {"changed": false, "failed": true, "module_stderr": "Traceback (most recent call last):\n  File \"/tmp/ansible_40xGwB/ansible_module_apt_repository.py\", line 538, in <module>\n    main()\n  File \"/tmp/ansible_40xGwB/ansible_module_apt_repository.py\", line 527, in main\n    cache.update()\n  File \"/usr/lib/python2.7/dist-packages/apt/cache.py\", line 464, in update\n    raise FetchFailedException(e)\napt.cache.FetchFailedException: E:The repository 'http://ppa.edx.org stretch Release' does not have a Release file.\n", "module_stdout": "", "msg": "MODULE FAILURE"}



I tried searching it online but could not find a solution for this. Can someone help we with this.

Thanks in advance.