Web lists-archives.com

Re: Update on my update problem with gnome system.




On Tue 29 May 2018 at 22:37:08 (+0100), Brian wrote:
> On Tue 29 May 2018 at 15:52:12 -0400, John Cunningham wrote:
> 
> > On Tue, May 29, 2018 at 3:39 PM Brian <ad44@xxxxxxxxxxxxxxx> wrote:
> > 
> > > On Tue 29 May 2018 at 21:57:31 +0300, Abdullah Ramazanoğlu wrote:
> > >
> > > > On Tue, 29 May 2018 13:18:16 -0500 David Wright said:
> > > > > On Tue 29 May 2018 at 18:38:40 (+0300), Abdullah Ramazanoğlu wrote:
> > > > > > On Tue, 29 May 2018 09:14:12 -0400 Greg Wooledge said:
> > > > > > > On Sat, May 26, 2018 at 09:31:14PM +0300, Abdullah Ramazanoğlu
> > > wrote:
> > > >
> > > > > --✁--------
> > > > > > > > I never use apt, so I am relying on the man page.
> > > > > --✃--------
> > > > >
> > > > > (That got snipped.)
> > > > >
> > > > > > > That's incorrect.  One of the differences between apt and apt-get
> > > is
> > > > > > > that apt WILL install new packages when doing "apt upgrade" (but it
> > > > > > > will not remove existing packages).
> > > > > > >
> > > > > > > Another difference is that apt will remove all of the .deb files
> > > from
> > > > > > > /var/cache/apt/archives that were downloaded for the CURRENT apt
> > > command
> > > > > > > session (but will not remove any that were already there).  (This
> > > > > > > behavior can be changed in a config file.)
> > > > > >
> > > > > > Hmm yes, apt upgrade do install new packages. I didn't look at the
> > > man page
> > > > > > for apt and assumed that -at least- the same keywords would work the
> > > same
> > > > > > in both apt and apt-get. I was wrong.
> > > > >
> > > > > Mmm.
> > > >
> > > > I think I owe an explanation regarding whether I referred to the man
> > > page or
> > > > not. :)
> > > >
> > > > For different operations and keywords like full-upgrade vs. dist-upgrade
> > > I did
> > > > refer to the man page, but it didn't occur to me that the exact same
> > > keyword
> > > > (upgrade) would behave different in apt, so I didn't cross check
> > > behavior of
> > > > "upgrade" in respective man pages. I simply assumed apt upgrade would
> > > behave
> > > > ditto apt-get upgrade.
> > > >
> > > > This is how I both do and don't look up at the man pages at the same
> > > time.
> > >
> > > If a package is upgraded, surely a user would want any new packages
> > > to be installed if they are required to satisfy dependencies. apt's
> > > designed behaviour looks more sensible than apt-get's.
> > 
> > Not necessarily. Sometimes the dependencies get out of hand, like when a
> > big project adopts a small utility and then decides that the entire project
> > is a dependency for the tiny utility.  It doesn't happen often, but it has
> > happened to me. I like that apt-get upgrade updates everything else. If I
> > decide I can stomach the other packages, I can always do a apt-get
> > dist-upgrade and install them.
> 
> Your unfortunate (and undetailed) experience has to be balanced against
> the benefits which accrue to most users in having an up-to-date Debian.

As I wrote (got snipped), "It [apt] wasn't designed to unify, but to
cherry-pick the parts most used by the "less sophisticated" (for want
of a better term) user. This explains the defaults chosen for it."
I guess that equates to your "most users". Fair enough.

In today's thread "File managers show files and directories in reverse order"
there was talk of Kate and Lyx, neither of which is installed here.
I toyed with installing kate just to see what the OP might be seeing.
Here's what would happen:

# apt-get -s install kate
Reading package lists...
Building dependency tree...
Reading state information...
The following additional packages will be installed:
  kactivities-bin kactivitymanagerd kate5-data kio kpackagelauncherqml
  kpackagetool5 ktexteditor-data ktexteditor-katepart libdbusmenu-qt5-2
  libfam0 libgit2-24 libgpgmepp6 libhttp-parser2.1 libkf5activities5
  libkf5archive5 libkf5attica5 libkf5auth-data libkf5auth5
  libkf5bookmarks-data libkf5bookmarks5 libkf5calendarevents5
  libkf5codecs-data libkf5codecs5 libkf5completion-data libkf5completion5
  libkf5config-bin libkf5config-data libkf5configcore5 libkf5configgui5
  libkf5configwidgets-data libkf5configwidgets5 libkf5coreaddons-data
  libkf5coreaddons5 libkf5crash5 libkf5dbusaddons-bin libkf5dbusaddons-data
  libkf5dbusaddons5 libkf5declarative-data libkf5declarative5
  libkf5globalaccel-bin libkf5globalaccel-data libkf5globalaccel5
  libkf5globalaccelprivate5 libkf5guiaddons5 libkf5i18n-data libkf5i18n5
  libkf5iconthemes-bin libkf5iconthemes-data libkf5iconthemes5
  libkf5itemmodels5 libkf5itemviews-data libkf5itemviews5
  libkf5jobwidgets-data libkf5jobwidgets5 libkf5kiocore5 libkf5kiofilewidgets5
  libkf5kiontlm5 libkf5kiowidgets5 libkf5newstuff-data libkf5newstuff5
  libkf5notifications-data libkf5notifications5 libkf5package-data
  libkf5package5 libkf5parts-data libkf5parts-plugins libkf5parts5
  libkf5plasma5 libkf5plasmaquick5 libkf5quickaddons5 libkf5service-bin
  libkf5service-data libkf5service5 libkf5solid5 libkf5solid5-data
  libkf5sonnet5-data libkf5sonnetcore5 libkf5sonnetui5 libkf5texteditor5
  libkf5textwidgets-data libkf5textwidgets5 libkf5threadweaver5
  libkf5wallet-bin libkf5wallet-data libkf5wallet5 libkf5widgetsaddons-data
  libkf5widgetsaddons5 libkf5windowsystem-data libkf5windowsystem5
  libkf5xmlgui-bin libkf5xmlgui-data libkf5xmlgui5 libkwalletbackend5-5
  libphonon4qt5-4 libpolkit-qt5-1-1 libpulse-mainloop-glib0 libqt5script5
  libxcb-composite0 libxcb-damage0 phonon4qt5 phonon4qt5-backend-vlc
  plasma-framework qml-module-org-kde-kquickcontrols
  qml-module-org-kde-kquickcontrolsaddons sonnet-plugins
Suggested packages:
  khelpcenter konsole-kpart fam media-player-info phonon4qt5-backend-gstreamer
  hspell
The following NEW packages will be installed:
  kactivities-bin kactivitymanagerd kate kate5-data kio kpackagelauncherqml
  kpackagetool5 ktexteditor-data ktexteditor-katepart libdbusmenu-qt5-2
  libfam0 libgit2-24 libgpgmepp6 libhttp-parser2.1 libkf5activities5
  libkf5archive5 libkf5attica5 libkf5auth-data libkf5auth5
  libkf5bookmarks-data libkf5bookmarks5 libkf5calendarevents5
  libkf5codecs-data libkf5codecs5 libkf5completion-data libkf5completion5
  libkf5config-bin libkf5config-data libkf5configcore5 libkf5configgui5
  libkf5configwidgets-data libkf5configwidgets5 libkf5coreaddons-data
  libkf5coreaddons5 libkf5crash5 libkf5dbusaddons-bin libkf5dbusaddons-data
  libkf5dbusaddons5 libkf5declarative-data libkf5declarative5
  libkf5globalaccel-bin libkf5globalaccel-data libkf5globalaccel5
  libkf5globalaccelprivate5 libkf5guiaddons5 libkf5i18n-data libkf5i18n5
  libkf5iconthemes-bin libkf5iconthemes-data libkf5iconthemes5
  libkf5itemmodels5 libkf5itemviews-data libkf5itemviews5
  libkf5jobwidgets-data libkf5jobwidgets5 libkf5kiocore5 libkf5kiofilewidgets5
  libkf5kiontlm5 libkf5kiowidgets5 libkf5newstuff-data libkf5newstuff5
  libkf5notifications-data libkf5notifications5 libkf5package-data
  libkf5package5 libkf5parts-data libkf5parts-plugins libkf5parts5
  libkf5plasma5 libkf5plasmaquick5 libkf5quickaddons5 libkf5service-bin
  libkf5service-data libkf5service5 libkf5solid5 libkf5solid5-data
  libkf5sonnet5-data libkf5sonnetcore5 libkf5sonnetui5 libkf5texteditor5
  libkf5textwidgets-data libkf5textwidgets5 libkf5threadweaver5
  libkf5wallet-bin libkf5wallet-data libkf5wallet5 libkf5widgetsaddons-data
  libkf5widgetsaddons5 libkf5windowsystem-data libkf5windowsystem5
  libkf5xmlgui-bin libkf5xmlgui-data libkf5xmlgui5 libkwalletbackend5-5
  libphonon4qt5-4 libpolkit-qt5-1-1 libpulse-mainloop-glib0 libqt5script5
  libxcb-composite0 libxcb-damage0 phonon4qt5 phonon4qt5-backend-vlc
  plasma-framework qml-module-org-kde-kquickcontrols
  qml-module-org-kde-kquickcontrolsaddons sonnet-plugins
0 upgraded, 106 newly installed, 0 to remove and 2 not upgraded.
Inst libqt5script5 (5.7.1~20161021+dfsg-2 Debian:9.4/stable [amd64])
Inst libhttp-parser2.1 (2.1-2 Debian:9.4/stable [amd64])
Inst libkf5activities5 (5.28.0-1 Debian:9.4/stable [amd64])
Inst kactivities-bin (5.28.0-1 Debian:9.4/stable [amd64])
Inst libkf5archive5 (5.28.0-2 Debian:9.4/stable [amd64])
Inst libkf5codecs-data (5.28.0-1 Debian:9.4/stable [all])
Inst libkf5codecs5 (5.28.0-1+b2 Debian:9.4/stable [amd64])
Inst libkf5completion-data (5.28.0-1 Debian:9.4/stable [all])
Inst libkf5config-data (5.28.0-2 Debian:9.4/stable [all])
Inst libkf5configcore5 (5.28.0-2 Debian:9.4/stable [amd64])
Inst libkf5configgui5 (5.28.0-2 Debian:9.4/stable [amd64])
Inst libkf5widgetsaddons-data (5.28.0-3 Debian:9.4/stable [all])
Inst libkf5widgetsaddons5 (5.28.0-3 Debian:9.4/stable [amd64])
Inst libkf5completion5 (5.28.0-1 Debian:9.4/stable [amd64])
Inst libkf5configwidgets-data (5.28.0-2 Debian:9.4/stable [all])
Inst libkf5auth-data (5.28.0-2 Debian:9.4/stable [all])
Inst libkf5coreaddons-data (5.28.0-2 Debian:9.4/stable [all])
Inst libfam0 (2.7.0-17.2+b1 Debian:9.4/stable [amd64])
Inst libkf5coreaddons5 (5.28.0-2 Debian:9.4/stable [amd64])
Inst libpolkit-qt5-1-1 (0.112.0-5 Debian:9.4/stable [amd64])
Inst libkf5auth5 (5.28.0-2 Debian:9.4/stable [amd64])
Inst libkf5guiaddons5 (5.28.0-1 Debian:9.4/stable [amd64])
Inst libkf5i18n-data (5.28.0-2 Debian:9.4/stable [all])
Inst libkf5i18n5 (5.28.0-2 Debian:9.4/stable [amd64])
Inst libkf5configwidgets5 (5.28.0-2 Debian:9.4/stable [amd64])
Inst libkf5dbusaddons-data (5.28.0-1 Debian:9.4/stable [all])
Inst libkf5dbusaddons5 (5.28.0-1 Debian:9.4/stable [amd64])
Inst libkf5itemviews-data (5.28.0-1 Debian:9.4/stable [all])
Inst libkf5itemviews5 (5.28.0-1 Debian:9.4/stable [amd64])
Inst libkf5windowsystem-data (5.28.0-2 Debian:9.4/stable [all])
Inst libkf5windowsystem5 (5.28.0-2 Debian:9.4/stable [amd64])
Inst libkf5crash5 (5.28.0-1 Debian:9.4/stable [amd64])
Inst libkf5service-data (5.28.0-1 Debian:9.4/stable [all])
Inst libkf5service5 (5.28.0-1 Debian:9.4/stable [amd64])
Inst libkf5service-bin (5.28.0-1 Debian:9.4/stable [amd64])
Inst libkf5kiocore5 (5.28.0-2 Debian:9.4/stable [amd64])
Inst libkf5kiontlm5 (5.28.0-2 Debian:9.4/stable [amd64])
Inst libkf5iconthemes-data (5.28.0-2 Debian:9.4/stable [all])
Inst libkf5iconthemes5 (5.28.0-2 Debian:9.4/stable [amd64])
Inst libkf5jobwidgets-data (5.28.0-2 Debian:9.4/stable [all])
Inst libkf5jobwidgets5 (5.28.0-2 Debian:9.4/stable [amd64])
Inst libkf5kiowidgets5 (5.28.0-2 Debian:9.4/stable [amd64])
Inst libkf5notifications-data (5.28.0-1 Debian:9.4/stable [all])
Inst libdbusmenu-qt5-2 (0.9.3+16.04.20160218-1 Debian:9.4/stable [amd64])
Inst libpulse-mainloop-glib0 (10.0-1+deb9u1 Debian:9.4/stable [amd64])
Inst libphonon4qt5-4 (4:4.9.0-4 Debian:9.4/stable [amd64])
Inst phonon4qt5-backend-vlc (0.9.0-2+deb9u1 Debian-Security:9/stable [amd64])
Inst phonon4qt5 (4:4.9.0-4 Debian:9.4/stable [amd64])
Inst libkf5notifications5 (5.28.0-1 Debian:9.4/stable [amd64])
Inst libkf5solid5-data (5.28.0-3 Debian:9.4/stable [all])
Inst libkf5solid5 (5.28.0-3 Debian:9.4/stable [amd64])
Inst libkf5textwidgets-data (5.28.0-1 Debian:9.4/stable [all])
Inst libkf5sonnet5-data (5.28.0-2 Debian:9.4/stable [all])
Inst libkf5sonnetcore5 (5.28.0-2 Debian:9.4/stable [amd64])
Inst libkf5sonnetui5 (5.28.0-2 Debian:9.4/stable [amd64])
Inst libkf5textwidgets5 (5.28.0-1 Debian:9.4/stable [amd64])
Inst libgpgmepp6 (1.8.0-3+b2 Debian:9.4/stable [amd64])
Inst libkf5wallet-data (5.28.0-3 Debian:9.4/stable [all])
Inst libkwalletbackend5-5 (5.28.0-3 Debian:9.4/stable [amd64])
Inst libkf5wallet5 (5.28.0-3 Debian:9.4/stable [amd64])
Inst libkf5wallet-bin (5.28.0-3 Debian:9.4/stable [amd64])
Inst kio (5.28.0-2 Debian:9.4/stable [amd64])
Inst libkf5globalaccel-data (5.28.0-1 Debian:9.4/stable [all])
Inst libkf5globalaccel5 (5.28.0-1 Debian:9.4/stable [amd64])
Inst libkf5xmlgui-data (5.28.0-1 Debian:9.4/stable [all])
Inst libkf5attica5 (5.28.0-1 Debian:9.4/stable [amd64])
Inst libkf5xmlgui5 (5.28.0-1 Debian:9.4/stable [amd64])
Inst kactivitymanagerd (5.8.4-1 Debian:9.4/stable [amd64])
Inst kate5-data (4:16.08.3-1 Debian:9.4/stable [all])
Inst ktexteditor-data (5.28.0-2 Debian:9.4/stable [all])
Inst libgit2-24 (0.25.1+really0.24.6-1 Debian:9.4/stable [amd64])
Inst libkf5parts-data (5.28.0-1 Debian:9.4/stable [all])
Inst libkf5parts5 (5.28.0-1 Debian:9.4/stable [amd64])
Inst libkf5texteditor5 (5.28.0-2 Debian:9.4/stable [amd64])
Inst ktexteditor-katepart (5.28.0-2 Debian:9.4/stable [amd64])
Inst libkf5declarative-data (5.28.0-1 Debian:9.4/stable [all])
Inst libkf5package-data (5.28.1-1 Debian:9.4/stable [all])
Inst libkf5package5 (5.28.1-1 Debian:9.4/stable [amd64])
Inst kpackagetool5 (5.28.1-1 Debian:9.4/stable [amd64])
Inst libkf5declarative5 (5.28.0-1 Debian:9.4/stable [amd64])
Inst qml-module-org-kde-kquickcontrols (5.28.0-1 Debian:9.4/stable [amd64])
Inst libkf5quickaddons5 (5.28.0-1 Debian:9.4/stable [amd64])
Inst qml-module-org-kde-kquickcontrolsaddons (5.28.0-1 Debian:9.4/stable [amd64])
Inst libkf5calendarevents5 (5.28.0-1 Debian:9.4/stable [amd64])
Inst libkf5plasma5 (5.28.0-2 Debian:9.4/stable [amd64])
Inst libkf5plasmaquick5 (5.28.0-2 Debian:9.4/stable [amd64])
Inst libxcb-composite0 (1.12-1 Debian:9.4/stable [amd64])
Inst libxcb-damage0 (1.12-1 Debian:9.4/stable [amd64])
Inst plasma-framework (5.28.0-2 Debian:9.4/stable [amd64])
Inst libkf5bookmarks-data (5.28.0-1 Debian:9.4/stable [all])
Inst libkf5bookmarks5 (5.28.0-1 Debian:9.4/stable [amd64])
Inst libkf5itemmodels5 (5.28.0-2 Debian:9.4/stable [amd64])
Inst libkf5kiofilewidgets5 (5.28.0-2 Debian:9.4/stable [amd64])
Inst libkf5newstuff-data (5.28.0-1 Debian:9.4/stable [all])
Inst libkf5newstuff5 (5.28.0-1 Debian:9.4/stable [amd64])
Inst libkf5threadweaver5 (5.28.0-1+b2 Debian:9.4/stable [amd64])
Inst kate (4:16.08.3-1 Debian:9.4/stable [amd64])
Inst kpackagelauncherqml (5.28.0-1 Debian:9.4/stable [amd64])
Inst libkf5config-bin (5.28.0-2 Debian:9.4/stable [amd64])
Inst libkf5dbusaddons-bin (5.28.0-1 Debian:9.4/stable [amd64])
Inst libkf5globalaccelprivate5 (5.28.0-1 Debian:9.4/stable [amd64])
Inst libkf5globalaccel-bin (5.28.0-1 Debian:9.4/stable [amd64])
Inst libkf5iconthemes-bin (5.28.0-2 Debian:9.4/stable [amd64])
Inst libkf5parts-plugins (5.28.0-1 Debian:9.4/stable [amd64])
Inst libkf5xmlgui-bin (5.28.0-1 Debian:9.4/stable [amd64])
Inst sonnet-plugins (5.28.0-2 Debian:9.4/stable [amd64])
Conf libqt5script5 (5.7.1~20161021+dfsg-2 Debian:9.4/stable [amd64])
Conf libhttp-parser2.1 (2.1-2 Debian:9.4/stable [amd64])
Conf libkf5activities5 (5.28.0-1 Debian:9.4/stable [amd64])
Conf kactivities-bin (5.28.0-1 Debian:9.4/stable [amd64])
Conf libkf5archive5 (5.28.0-2 Debian:9.4/stable [amd64])
Conf libkf5codecs-data (5.28.0-1 Debian:9.4/stable [all])
Conf libkf5codecs5 (5.28.0-1+b2 Debian:9.4/stable [amd64])
Conf libkf5completion-data (5.28.0-1 Debian:9.4/stable [all])
Conf libkf5config-data (5.28.0-2 Debian:9.4/stable [all])
Conf libkf5configcore5 (5.28.0-2 Debian:9.4/stable [amd64])
Conf libkf5configgui5 (5.28.0-2 Debian:9.4/stable [amd64])
Conf libkf5widgetsaddons-data (5.28.0-3 Debian:9.4/stable [all])
Conf libkf5widgetsaddons5 (5.28.0-3 Debian:9.4/stable [amd64])
Conf libkf5completion5 (5.28.0-1 Debian:9.4/stable [amd64])
Conf libkf5configwidgets-data (5.28.0-2 Debian:9.4/stable [all])
Conf libkf5auth-data (5.28.0-2 Debian:9.4/stable [all])
Conf libkf5coreaddons-data (5.28.0-2 Debian:9.4/stable [all])
Conf libfam0 (2.7.0-17.2+b1 Debian:9.4/stable [amd64])
Conf libkf5coreaddons5 (5.28.0-2 Debian:9.4/stable [amd64])
Conf libpolkit-qt5-1-1 (0.112.0-5 Debian:9.4/stable [amd64])
Conf libkf5auth5 (5.28.0-2 Debian:9.4/stable [amd64])
Conf libkf5guiaddons5 (5.28.0-1 Debian:9.4/stable [amd64])
Conf libkf5i18n-data (5.28.0-2 Debian:9.4/stable [all])
Conf libkf5i18n5 (5.28.0-2 Debian:9.4/stable [amd64])
Conf libkf5configwidgets5 (5.28.0-2 Debian:9.4/stable [amd64])
Conf libkf5dbusaddons-data (5.28.0-1 Debian:9.4/stable [all])
Conf libkf5dbusaddons5 (5.28.0-1 Debian:9.4/stable [amd64])
Conf libkf5itemviews-data (5.28.0-1 Debian:9.4/stable [all])
Conf libkf5itemviews5 (5.28.0-1 Debian:9.4/stable [amd64])
Conf libkf5windowsystem-data (5.28.0-2 Debian:9.4/stable [all])
Conf libkf5windowsystem5 (5.28.0-2 Debian:9.4/stable [amd64])
Conf libkf5crash5 (5.28.0-1 Debian:9.4/stable [amd64])
Conf libkf5service-data (5.28.0-1 Debian:9.4/stable [all])
Conf libkf5service5 (5.28.0-1 Debian:9.4/stable [amd64])
Conf libkf5service-bin (5.28.0-1 Debian:9.4/stable [amd64])
Conf libkf5kiocore5 (5.28.0-2 Debian:9.4/stable [amd64])
Conf libkf5kiontlm5 (5.28.0-2 Debian:9.4/stable [amd64])
Conf libkf5iconthemes-data (5.28.0-2 Debian:9.4/stable [all])
Conf libkf5iconthemes5 (5.28.0-2 Debian:9.4/stable [amd64])
Conf libkf5jobwidgets-data (5.28.0-2 Debian:9.4/stable [all])
Conf libkf5jobwidgets5 (5.28.0-2 Debian:9.4/stable [amd64])
Conf libkf5kiowidgets5 (5.28.0-2 Debian:9.4/stable [amd64])
Conf libkf5notifications-data (5.28.0-1 Debian:9.4/stable [all])
Conf libdbusmenu-qt5-2 (0.9.3+16.04.20160218-1 Debian:9.4/stable [amd64])
Conf libpulse-mainloop-glib0 (10.0-1+deb9u1 Debian:9.4/stable [amd64])
Conf libphonon4qt5-4 (4:4.9.0-4 Debian:9.4/stable [amd64])
Conf phonon4qt5-backend-vlc (0.9.0-2+deb9u1 Debian-Security:9/stable [amd64])
Conf phonon4qt5 (4:4.9.0-4 Debian:9.4/stable [amd64])
Conf libkf5notifications5 (5.28.0-1 Debian:9.4/stable [amd64])
Conf libkf5solid5-data (5.28.0-3 Debian:9.4/stable [all])
Conf libkf5solid5 (5.28.0-3 Debian:9.4/stable [amd64])
Conf libkf5textwidgets-data (5.28.0-1 Debian:9.4/stable [all])
Conf libkf5sonnet5-data (5.28.0-2 Debian:9.4/stable [all])
Conf libkf5sonnetcore5 (5.28.0-2 Debian:9.4/stable [amd64])
Conf libkf5sonnetui5 (5.28.0-2 Debian:9.4/stable [amd64])
Conf libkf5textwidgets5 (5.28.0-1 Debian:9.4/stable [amd64])
Conf libgpgmepp6 (1.8.0-3+b2 Debian:9.4/stable [amd64])
Conf libkf5wallet-data (5.28.0-3 Debian:9.4/stable [all])
Conf libkwalletbackend5-5 (5.28.0-3 Debian:9.4/stable [amd64])
Conf libkf5wallet5 (5.28.0-3 Debian:9.4/stable [amd64])
Conf libkf5wallet-bin (5.28.0-3 Debian:9.4/stable [amd64])
Conf kio (5.28.0-2 Debian:9.4/stable [amd64])
Conf libkf5globalaccel-data (5.28.0-1 Debian:9.4/stable [all])
Conf libkf5globalaccel5 (5.28.0-1 Debian:9.4/stable [amd64])
Conf libkf5xmlgui-data (5.28.0-1 Debian:9.4/stable [all])
Conf libkf5attica5 (5.28.0-1 Debian:9.4/stable [amd64])
Conf libkf5xmlgui5 (5.28.0-1 Debian:9.4/stable [amd64])
Conf kactivitymanagerd (5.8.4-1 Debian:9.4/stable [amd64])
Conf kate5-data (4:16.08.3-1 Debian:9.4/stable [all])
Conf ktexteditor-data (5.28.0-2 Debian:9.4/stable [all])
Conf libgit2-24 (0.25.1+really0.24.6-1 Debian:9.4/stable [amd64])
Conf libkf5parts-data (5.28.0-1 Debian:9.4/stable [all])
Conf libkf5parts5 (5.28.0-1 Debian:9.4/stable [amd64])
Conf libkf5texteditor5 (5.28.0-2 Debian:9.4/stable [amd64])
Conf ktexteditor-katepart (5.28.0-2 Debian:9.4/stable [amd64])
Conf libkf5declarative-data (5.28.0-1 Debian:9.4/stable [all])
Conf libkf5package-data (5.28.1-1 Debian:9.4/stable [all])
Conf libkf5package5 (5.28.1-1 Debian:9.4/stable [amd64])
Conf kpackagetool5 (5.28.1-1 Debian:9.4/stable [amd64])
Conf libkf5declarative5 (5.28.0-1 Debian:9.4/stable [amd64])
Conf qml-module-org-kde-kquickcontrols (5.28.0-1 Debian:9.4/stable [amd64])
Conf libkf5quickaddons5 (5.28.0-1 Debian:9.4/stable [amd64])
Conf qml-module-org-kde-kquickcontrolsaddons (5.28.0-1 Debian:9.4/stable [amd64])
Conf libkf5calendarevents5 (5.28.0-1 Debian:9.4/stable [amd64])
Conf libkf5plasma5 (5.28.0-2 Debian:9.4/stable [amd64])
Conf libkf5plasmaquick5 (5.28.0-2 Debian:9.4/stable [amd64])
Conf libxcb-composite0 (1.12-1 Debian:9.4/stable [amd64])
Conf libxcb-damage0 (1.12-1 Debian:9.4/stable [amd64])
Conf plasma-framework (5.28.0-2 Debian:9.4/stable [amd64])
Conf libkf5bookmarks-data (5.28.0-1 Debian:9.4/stable [all])
Conf libkf5bookmarks5 (5.28.0-1 Debian:9.4/stable [amd64])
Conf libkf5itemmodels5 (5.28.0-2 Debian:9.4/stable [amd64])
Conf libkf5kiofilewidgets5 (5.28.0-2 Debian:9.4/stable [amd64])
Conf libkf5newstuff-data (5.28.0-1 Debian:9.4/stable [all])
Conf libkf5newstuff5 (5.28.0-1 Debian:9.4/stable [amd64])
Conf libkf5threadweaver5 (5.28.0-1+b2 Debian:9.4/stable [amd64])
Conf kate (4:16.08.3-1 Debian:9.4/stable [amd64])
Conf kpackagelauncherqml (5.28.0-1 Debian:9.4/stable [amd64])
Conf libkf5config-bin (5.28.0-2 Debian:9.4/stable [amd64])
Conf libkf5dbusaddons-bin (5.28.0-1 Debian:9.4/stable [amd64])
Conf libkf5globalaccelprivate5 (5.28.0-1 Debian:9.4/stable [amd64])
Conf libkf5globalaccel-bin (5.28.0-1 Debian:9.4/stable [amd64])
Conf libkf5iconthemes-bin (5.28.0-2 Debian:9.4/stable [amd64])
Conf libkf5parts-plugins (5.28.0-1 Debian:9.4/stable [amd64])
Conf libkf5xmlgui-bin (5.28.0-1 Debian:9.4/stable [amd64])
Conf sonnet-plugins (5.28.0-2 Debian:9.4/stable [amd64])
# 

AFAICT apt does the same but prefixed by:
WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

I don't know if kate is a "small utility" but 106 packages does seem
to be getting "out of hand". Anyway, thanks but no thanks.

Cheers,
David.