Web lists-archives.com

upgrade to X 1.20.0 broken




Hello,

I am running sid, and updated to X.org 1.20.0. Since then I cannot login.

I am running lightdm with xfce. lightdm comes up just fine, but when I login,
after a second or two, it comes back to the lightdm login screen. I have
an old
graphics card (EVGA 6600GT) and monitor (NEC 1970GX) from 2005. They use the
nouveau display driver.

Has anyone else run into this problem? I am not sure if this is an
xserver-xorg-core problem or an nouveau problem. The only change for nouveau
that I am aware of is that xserver-xorg-video-nouveau was rebuilt against
xserver 1.20.

Below are the error messages that I could find. I'm not sure how to interpret
the backtrace.


from /home/myhome/.xsession-errors:

dbus-update-activation-environment: setting
XDG_DATA_DIRS=/usr/share/xfce4:/usr/local/share/:/usr/share/
/usr/bin/x-session-manager: X server already running on display :0
xfce4-session-Message: 14:51:48.954: SSH authentication agent is already
running
gpg-agent[1243]: WARNING: "--write-env-file" is an obsolete option - it
has no effect
gpg-agent: a gpg-agent is already running - not starting a new one

(xfce4-session:1226): xfce4-session-WARNING **: 14:51:48.958: gpg-agent
returned no PID in the variables
Thunar: Cannot open display:
xfwm4: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.0.
xfce4-session: Fatal IO error 11 (Resource temporarily unavailable) on X
server :0.


from /var/log/Xorg.0.log:

[  7878.421] (EE)
[  7878.421] (EE) Backtrace:
[  7878.422] (EE) 0: /usr/lib/xorg/Xorg (xorg_backtrace+0x4d)
[0x5571771ab6fd]
[  7878.422] (EE) 1: /usr/lib/xorg/Xorg (0x557176ff8000+0x1b73b9)
[0x5571771af3b9]
[  7878.422] (EE) 2: /lib/x86_64-linux-gnu/libpthread.so.0
(0x7fdff8720000+0x11f50) [0x7fdff8731f50]
[  7878.422] (EE) 3: /usr/lib/xorg/Xorg (miRenderColorToPixel+0xe)
[0x55717711fa9e]
[  7878.422] (EE) 4: /usr/lib/xorg/modules/libexa.so
(0x7fdff5190000+0xf12b) [0x7fdff519f12b]
[  7878.422] (EE) 5: /usr/lib/xorg/Xorg (0x557176ff8000+0x13a786)
[0x557177132786]
[  7878.422] (EE) 6: /usr/lib/xorg/Xorg (0x557176ff8000+0x12eaec)
[0x557177126aec]
[  7878.422] (EE) 7: /usr/lib/xorg/Xorg (0x557176ff8000+0x5b008)
[0x557177053008]
[  7878.422] (EE) 8: /usr/lib/xorg/Xorg (0x557176ff8000+0x5f008)
[0x557177057008]
[  7878.422] (EE) 9: /lib/x86_64-linux-gnu/libc.so.6
(__libc_start_main+0xe7) [0x7fdff8381a87]
[  7878.422] (EE) 10: /usr/lib/xorg/Xorg (_start+0x2a) [0x557177040d0a]
[  7878.422] (EE)
[  7878.422] (EE) Segmentation fault at address 0x8
[  7878.422] (EE)
Fatal server error:
[  7878.422] (EE) Caught signal 11 (Segmentation fault). Server aborting
[  7878.422] (EE)
[  7878.422] (EE)
Please consult the The X.Org Foundation support
	 at http://wiki.x.org
 for help.
[  7878.422] (EE) Please also check the log file at "/var/log/Xorg.0.log"
for additional information.
[  7878.422] (EE)
[  7878.422] (II) AIGLX: Suspending AIGLX clients for VT switch
[  7878.422] (II) NOUVEAU(0): NVLeaveVT is called.
[  7878.423] (EE) Server terminated with error (1). Closing log file.


Thanks for any help.
Roger