Web lists-archives.com

Re: regex in apt preferences




On Mon, 7 May 2018 08:26:35 +0000 (UTC) David Griffith said:

> Package: *systemd*
> Pin: release *
> Pin-Priority: -1
> 
> This will prevent anything requiring systemd from being accidentally
> installed.  This also prevents libsystemd0 from being updated.

Package: *systemd*
Pin: release *
Pin-Priority: -1

Package: libsystemd0
Pin: release a=testing
Pin-Priority: 500

Second entry overrides the first one, so all *systemd* packages except
libsystemd0 are given -1 priority.

Note: Instead of "a=testing" or "a=stable" stick to the exact release name you
are using in sources.list (it will be important when buster becomes the next
stable)

Regards
-- 
Abdullah Ramazanoğlu