Web lists-archives.com

Re: pkg-config: required as dep so often - How and where to report?




On Fri, May 04, 2018 at 05:26:22PM +0200, Sven Joachim wrote:
> On 2018-05-04 09:58 -0400, Greg Wooledge wrote:
> 
> > On Fri, May 04, 2018 at 03:48:26PM +0200, Alexander Traud wrote:
> >> To compile a (quite large) project, I had to install several packages
> >> (dependencies). The project required the tool pkg-config. However, that
> >> was not mentioned anywhere. Still the project compiled/built, because
> >> one of the other dependencies (libsrtp2-dev) installed pkg-config as
> >> side effect. So, I had pure luck that it succeeded.
> >
> > libc6-dev depends on pkg-config,
> 
> Huh?  No it doesn't:
> 
> $ apt-cache show libc6-dev | grep Depends
> Depends: libc6 (= 2.27-3), libc-dev-bin (= 2.27-3), linux-libc-dev

Oh, sorry.  I used apt-cache show libc6-dev and saw the super long list
of packages and versions that includes pkg-config, and missed the fact
that it was a Breaks: line instead of a Depends: line.

wooledg:~$ apt-cache depends libc6-dev
libc6-dev
  Depends: libc6
  Depends: libc-dev-bin
    libc-dev-bin:i386
  Depends: linux-libc-dev
  Conflicts: <libc0.1-dev>
  Conflicts: <libc0.3-dev>
  Conflicts: <libc6.1-dev>
  Breaks: binutils
  Breaks: <binutils-gold>
  Breaks: cmake
  Breaks: <gcc-4.4>
  Breaks: <gcc-4.5>
  Breaks: <gcc-4.6>
  Breaks: libhwloc-dev
  Breaks: libjna-java
  Breaks: liblouis-dev
  Breaks: liblouisxml-dev
  Breaks: make
  Breaks: pkg-config
  Suggests: glibc-doc
  Suggests: manpages-dev