Web lists-archives.com

Debian 9 t: Update Gstreamer Base plugins package to resolve a Gstreamer bug




Hi team,
I develop applications that does multimedia I/O on Linux. I have noticed stalls on Debian 9 due to a bug in Gstreamer 1.10. The Gstreamer developers have acknowledged this as a bug and have fixed this for the 1.14 line of Gstreamer. As I use the Gstreamer that comes by default on the platform, this fix needs to be ported to  the 1.10 line.

The bug report is here: https://bugzilla.gnome.org/show_bug.cgi?id=795551

The dev who fixed the bug had the following comment:
"You'll have to talk to whoever is providing you your older version of GStreamer. They will have to backport the fix to that old version, but it should just cleanly apply to the older versions."

The patch that needs to be applied is:
https://github.com/GStreamer/gst-plugins-base/commit/9f9000e693694ea33c21607140ffc29aa1734062#diff-acf6f1abae3d918458c7a91ce8a0b3ad

Is this something that would be possible to do? This would really help me as this stall is a show stopper for my application.

Regards,
Dinesh