Web lists-archives.com

Re: gegl: symbol lookup error: /usr/lib/x86_64-linux-gnu/libgegl-0.4.so.0: undefined symbol: babl_process_rows




On 2018-05-02 22:44 +0200, Johann Spies wrote:

> I have installed gimp 2.10 on three computers.  On two it was
> successful.  On the third I get the error in the subject line whenever
> I run gimp or gegl.  On the computer where I get this error, I could
> also not compile the source package for gegl.  I could on of the
> others and then I copied the compiled packages to the problem computer
> and installed it but I made no progress to solving the problem.
>
> I even upgraded that computer to unstable and purged and reinstalled
> all the x11-related packages but I could not find out what the problem
> was.
>
> How do I determine what is causing the problem and then solve it?

A common cause for symbol lookup errors is locally installed libraries
not under dpkg control.  Start by running "ldd /usr/bin/gimp" and watch
for anything unusual, such as libraries under /usr/local.

> $ wajig list babl
> ii  libbabl-0.1-0:amd64
> 0.1.46-2                            amd64        Dynamic, any to any,
> pixel format conversion library
> ii  libbabl-dev:amd64
> 0.1.46-2                            amd64        Dynamic, any to any,
> pixel format conversion library (develo..

Previous reports of your problem have been #896091 and #897226, but
those were due to having libbabl-0.1-0 from dmo installed.  Apparently
this is not the case on your system.

Cheers,
       Sven