Web lists-archives.com

Re: ACPI Error on boot




On Thu, 12 Apr 2018, Anil Duggirala wrote:
> I am also getting missing firmware notices, namely,
> [    9.269384] ath10k_pci 0000:03:00.0: firmware: failed to load ath10k/pre-cal-pci-0000:03:00.0.bin (-2)
> [    9.269386] ath10k_pci 0000:03:00.0: Direct firmware load for ath10k/pre-cal-pci-0000:03:00.0.bin failed with error -2
> [    9.269403] ath10k_pci 0000:03:00.0: firmware: failed to load ath10k/cal-pci-0000:03:00.0.bin (-2)
> [    9.269404] ath10k_pci 0000:03:00.0: Direct firmware load for ath10k/cal-pci-0000:03:00.0.bin failed with error -2
> [    9.311104] ath10k_pci 0000:03:00.0: firmware: failed to load ath10k/QCA6174/hw3.0/firmware-5.bin (-2)
> [    9.311107] ath10k_pci 0000:03:00.0: Direct firmware load for ath10k/QCA6174/hw3.0/firmware-5.bin failed with error -2
> [    9.311113] ath10k_pci 0000:03:00.0: could not fetch firmware file 'ath10k/QCA6174/hw3.0/firmware-5.bin': -2
> 
> Could the other ACPI Errors be related to this missing firmware?

No.  And in the specific case of ath10k, which actually searches for
firmware in descending preference order, it is sort of normal to get
these annoying logs even if you have the correct firmware package
installed.  It is being addressed on a future kernel so that such
searches can be made silent.

> Do you also recommend updating my BIOS?

Keep that thing up-to-date, maybe with an one-month delay to let the
vendor recall bad updates (they are rare, but it has happened to some),
or looking around at forums to see if anyone is complaining of issues
before you apply the update.

-- 
  Henrique Holschuh