Web lists-archives.com

Re: Error while upgrading from Wheezy to Stretch




On Wed, 11 Apr 2018 15:31:32 -0400 David Parker <dparker@xxxxxxxxx>
wrote:

> Hello,
> 
> I am trying to upgrade two test boxes from Wheezy to Stretch (skipping
> Jessie).  The upgrade worked on one of them, although I ran into
> errors and had to run "apt-get -f install" a few times, but that
> resolved the issues and it ultimately worked.
> 
> However, on the second box, I ran into an error about halfway through
> the upgrade, and I'm not able to get past it.  No matter what I do, I
> keep running into version mismatch issue with libpam-modules.  It's
> preventing the upgrade from finishing.
> 
> # apt-get -f install
> [snip]
> 
> Any ideas or suggestions for resolving this will be greatly
> appreciated.

Yes.  Retore both Wheezy systems from their respective back ups Then
read and follow the upgarde instructions which you should have done
first. And DON'T skip upgrading to interim releases to save time
thinking it's not necessary.  That piece of advice is in the
iinstructions, too, along with a lot of other wisdom to make your
upgrade as unproblematical as possible.

B