Web lists-archives.com

Re: apt{-cache,-get,itude} show wrong version of package after update




Jean-Baptiste Thomas wrote:
> /var/lib/apt/lists/, which may be why it thinks that not being
> able to download it is not a problem.
>
> Unfortunately, the Packages file in /var/lib/apt/lists/ is out
> of date by months because it pertains to 9.2 while the mirror
> has 9.4. Diffing the two shows why apt-get looks for the wrong
> version of ntp :
>
>  Package: ntp
> -Version: 1:4.2.8p10+dfsg-3+deb9u1
> +Version: 1:4.2.8p10+dfsg-3+deb9u2
>  Installed-Size: 1804
>
> What I'd like to know now is : what prevents apt-get from
> downloading the Packages file from the mirror ? Wget can !
>
> [1] https://superuser.com/questions/454867/

  since you seem to be skipping versions a bit i'd
try:

  apt-get dist-upgrade

  or similar command using your preferred tool.

  may help or give more information...

  if you are using a certain repository and are
still seeing errors after that it may be worth
specifying a different one or the more general
default.

  usually when i do this i erase all my local
apt files in /var/lib/apt/lists) so they will be
redownloaded.


  songbird