Web lists-archives.com

Re: dependancies issues




On Wed, 28 Mar 2018 09:46:53 -0400 The Wanderer said:
> On 2018-03-28 at 09:39, Laurent Debian wrote:
> 
> > Dear all,
> > I have one question
> > Does that aptitude message looks normal to you :"
> > 
> > "python-tornado breaks : python-zmq (< 17) but 16.0.2-2+b1 is to be
> > installed"
> > 
> > Does I misunderstand or does it looks like aptitude thinks that
> > 16.0... is not less than 17 ?  
> 
> No, it's saying "because the version of python-zmq which is selected
> for installation is 16.x, we can't install a version of
> python-tornado which says it only works with version 17 and above".
> 
> Why version 16.x is selected for installation is another question, but
> we don't have enough information to go on in that regard.

Sorry but I still don't get it. As I understand, aptitude appears to
say that python-zmq with version *less than* 17 is needed?

That aside, python-tornado and python-zmq neither depends nor conflicts
with one another. It may be different for Stretch, though.

# both tornado and zmq is not currently installed
~$ dpkg -l python-tornado python-zmq
dpkg-query: no packages found matching python-tornado
dpkg-query: no packages found matching python-zmq

# tornado has nothing (directly) to do with zmq
~$ apt-cache show python-tornado
Package: python-tornado
Version: 5.0.0-1
Installed-Size: 1682
Maintainer: Debian Python Modules Team
<python-modules-team@xxxxxxxxxxxxxxxxxxxxxxx> Architecture: amd64
Depends: ca-certificates, python (<< 2.8), python (>= 2.7~),
python-backports-abc, python-concurrent.futures, python-singledispatch,
python:any (<< 2.8), python:any (>= 2.7.5-5~), libc6 (>= 2.4)

# zmq has nothing (directly) to do with tornado
~$ apt-cache show python-zmq
Package: python-zmq
Source: pyzmq (16.0.2-2)
Version: 16.0.2-2+b1
Installed-Size: 1185
Maintainer: Debian Python Modules Team
<python-modules-team@xxxxxxxxxxxxxxxxxxxxxxx> Architecture: amd64
Depends: python (<< 2.8), python (>= 2.7~), python:any (<< 2.8),
python:any (>= 2.7.5-5~), libc6 (>= 2.14), libzmq5 (>= 4.1.2)

# tornado has nothing (directly or indirectly) to do with zmq
~$ apt-get -s install python-tornado
...
The following additional packages will be installed:
  python-backports-abc python-singledispatch
Suggested packages:
  python-mysqldb python-tornado-doc python-twisted
The following NEW packages will be installed:
  python-backports-abc python-singledispatch python-tornado
0 upgraded, 3 newly installed, 0 to remove and 401 not upgraded.
Inst python-backports-abc (0.5-2 Debian:testing [all])
Inst python-singledispatch (3.4.0.3-2 Debian:testing [all])
Inst python-tornado (5.0.0-1 Debian:testing [amd64])
Conf python-backports-abc (0.5-2 Debian:testing [all])
Conf python-singledispatch (3.4.0.3-2 Debian:testing [all])
Conf python-tornado (5.0.0-1 Debian:testing [amd64])

# zmq has nothing (directly or indirectly) to do with tornado
~$ apt-get -s install python-zmq
...
The following NEW packages will be installed:
  python-zmq
0 upgraded, 1 newly installed, 0 to remove and 401 not upgraded.
Inst python-zmq (16.0.2-2+b1 Debian:testing [amd64])
Conf python-zmq (16.0.2-2+b1 Debian:testing [amd64])

So, where exactly python-zmq enters the picture, I don't know.

Regards
-- 
Abdullah Ramazanoglu