Web lists-archives.com

bad upgrade libgstgl-1.0.so.0




Hi,

I had a bad upgrade on my debian sid.

It seems both libgstreamer-gl1.0-0:amd64 and
libgstreamer-plugins-bad1.0-0:amd64 are trying to write the file
/usr/lib/x86_64-linux-gnu/libgstgl-1.0.so.0.

Any idea to fix it?

Pétùr

# apt upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 gir1.2-gst-plugins-base-1.0 : Depends: libgstreamer-gl1.0-0 (>= 1.14.0)
but it is not installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages
(or specify a solution).

# apt --fix-broken install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following additional packages will be installed:
  gstreamer1.0-gl libgstreamer-gl1.0-0
The following NEW packages will be installed:
  gstreamer1.0-gl libgstreamer-gl1.0-0
0 upgraded, 2 newly installed, 0 to remove and 25 not upgraded.
1 not fully installed or removed.
Need to get 0 B/2 616 kB of archives.
After this operation, 3 169 kB of additional disk space will be used.
Do you want to continue? [O/n]
(Reading database ... 429315 files and directories currently installed.)
Preparing to unpack .../libgstreamer-gl1.0-0_1.14.0-1_amd64.deb ...
Unpacking libgstreamer-gl1.0-0:amd64 (1.14.0-1) ...
dpkg: error processing archive
/var/cache/apt/archives/libgstreamer-gl1.0-0_1.14.0-1_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/x86_64-linux-gnu/libgstgl-1.0.so.0',
which is also in package libgstreamer-plugins-bad1.0-0:amd64 1:1.12.4-dmo4
Preparing to unpack .../gstreamer1.0-gl_1.14.0-1_amd64.deb ...
Unpacking gstreamer1.0-gl:amd64 (1.14.0-1) ...
dpkg: error processing archive
/var/cache/apt/archives/gstreamer1.0-gl_1.14.0-1_amd64.deb (--unpack):
 trying to overwrite
'/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstopengl.so', which is also
in package gstreamer1.0-plugins-bad:amd64 1:1.12.4-dmo4
dpkg-deb: error: paste subprocess was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/libgstreamer-gl1.0-0_1.14.0-1_amd64.deb
 /var/cache/apt/archives/gstreamer1.0-gl_1.14.0-1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)