Web lists-archives.com

Re: Missing Shared Object File for ffmpeg




On Tue 20 Mar 2018 at 08:41:05 (+0000), Curt wrote:
> On 2018-03-20, <tomas@xxxxxxxxxx> <tomas@xxxxxxxxxx> wrote:
> >
> > Try "apt-file search" (in package apt-file):
> >
> >   tomas@trotzki:~$ apt-file search libopenal.so.1
> >   libopenal1: /usr/lib/x86_64-linux-gnu/libopenal.so.1
> >   libopenal1: /usr/lib/x86_64-linux-gnu/libopenal.so.1.17.2
> >
> > I guess libopenal gets loaded on-demand as a plugin. Are you
> > sure you are trying the same video on both systems? Otherwise,
> > I don't have an idea on what could cause this difference.
> >
> 
> Yes the package is libopenal1. I don't have the package in Stretch,
> though ffmpeg is installed.

In my ftp.us.debian.org_debian_dists_stretch_main_binary-amd64_Packages
(39116092 Mar 10 03:33) ffmpeg says:

Package: ffmpeg
Version: 7:3.2.10-1~deb9u1
Installed-Size: 2137
Maintainer: Debian Multimedia Maintainers <pkg-multimedia-maintainers@xxxxxxxxxxxxxxxxxxxxxxx>
Architecture: amd64
Replaces: libav-tools (<< 6:12~~), qt-faststart (<< 7:2.7.1-3~)
Depends: libavcodec57 (>= 7:3.2.10) | libavcodec-extra57 (>= 7:3.2.10), libavdevice57 (>= 7:3.2.10), …

and libavdevice57 says:

Package: libavdevice57
Source: ffmpeg
Version: 7:3.2.10-1~deb9u1
Installed-Size: 278
Maintainer: Debian Multimedia Maintainers <pkg-multimedia-maintainers@xxxxxxxxxxxxxxxxxxxxxxx>
Architecture: amd64
Depends: libasound2 (>= 1.0.16), libavc1394-0 (>= 0.5.3), libavcodec57 (>= 7:3.2.10) |
 libavcodec-extra57 (>= 7:3.2.10), libavfilter6 (>= 7:3.2.10) | libavfilter-extra6 (>= 7:3.2.10),
 libavformat57 (>= 7:3.2.10), libavutil55 (>= 7:3.2.10), libc6 (>= 2.14), libcaca0 (>= 0.99.beta17-1),
 libcdio-cdda1 (>= 0.83), libcdio-paranoia1 (>= 0.83), libdc1394-22, libgl1-mesa-glx | libgl1,
 libiec61883-0 (>= 1.2.0), libjack-jackd2-0 (>= 1.9.10+20150825) | libjack-0.125, libopenal1 (>= 1.14), …

so how do you get around not installing libopenal1?

BTW Greg,   aptitude why libopenal1   might not help because it only
displays the “most installed, strongest, tightest, shortest”
dependency chain, which here is:

i   mplayer-gui Depends libopenal1 (>= 1.14)

>  ffmpeg -formats 
> 
> informs me that my ffmpeg was configured with "--enable-openal" and
> includes the "D  openal          OpenAL audio capture device".
> 
> This post is probably what they call "superfétatoire" in French.

Cheers,
David.