Web lists-archives.com

Re: Problems with KDE in Debian Stretch

Daniel Bareiro composed on 2018-03-11 00:35 (UTC-0300):
> I think that before adding the file with the configuration that I
> mentioned (/usr/share/X11/xorg.conf.d/20-intel.conf), I was using the
> default driver. At least I don't have a /etc/X11/xorg.conf file.

> In essence the configuration I suppose that it will have been the same
> one that I kept previously with Jessie and with which it was not having
> problems with Jessie.
> Currently I have these packages installed:
> i A xserver-xorg-video-all - X.Org X server -- output driver metapackage
> i A xserver-xorg-video-intel - X.Org X server -- Intel i8xx, i9xx display driver
> I guess these would be the same packages I was using with Jessie (if so,
> I suppose I would also have installed xserver-xorg-video-intel), but
> honestly, I don't have registered the ones I had installed then.

A default install of either Jessie or Stretch includes xserver-xorg-video-all,
and thus xserver-xorg-video-intel. Thus with your 3rd Gen Core, it's virtually
impossible that you weren't using the intel driver in Jessie, and unlikely in

It's simple enough to try the modeset(0) driver. Simply purge
xserver-xorg-video-intel, rename 20-intel.conf, and restart the xserver. Either
it's better, or it's not. If not, reinstall xserver-xorg-video-intel, restore
20-intel.conf (or not), and restart the xserver.

If nothing helps, try going into desktop settings and disabling compositing. If
that doesn't help either, ask on intel-gfx@xxxxxxxxxxxxxxxxxxxxx which is a
hangout of Intel driver devs. Include 'lspci -nnk | grep -A3 VGA' output and
pastebin Xorg.0.log.
"Wisdom is supreme; therefore get wisdom. Whatever else you
get, get wisdom." Proverbs 4:7 (New Living Translation)

 Team OS/2 ** Reg. Linux User #211409 ** a11y rocks!

Felix Miata  ***  http://fm.no-ip.com/