Web lists-archives.com

Re: set default print options on printer




On 2018-03-08 09:50 AM, Brian wrote:
On Wed 07 Mar 2018 at 21:35:02 -0500, Gary Dale wrote:

I have a Samsung C410 printer attached to a Stretch server via USB and also
available via wifi. There doesn't seem to be a default print setting for
paper size but the cups listing for the printer shows:

    Defaults:job-sheets=none, none media=na_letter_8.5x11in sides=one-sided

which is correct.
na_letter_8.5x11in is the default size taken from the PPD for the queue
when it was set up. Presumably it is "correct" because it suited you. The
default media size can be changed; via the CUPS web interface is one way.
The new size would also be "correct".

The default size can be overridden by CUPS in a number of ways, usually
with the help of lpoptions. This new size is also "correct".
It is correct because that is what is in the paper tray. There is no default paper size setting for this printer through the CUPS web interface. I know that is unusual but it is the way that printer's CUPS driver seems to work.


                   However when I try to print a PDF using Okular, the paper
size is set to A4. If I forget to change it to letter, the print gets
chopped off at the top.
Okular uses the default size setting in the PPD if nothing else overrides
it. If it is offering A4, it is being informed of the "correct" size by
something.
Perhaps but CUPS reports that the default paper size is letter while Okular thinks it it is A4.

Please post the output of 'lpoptions -p <C410_queue_name>.
$lpoptions -p Samsung_C410_Series
copies=1 device-uri=socket://192.168.1.12 finishings=3 job-cancel-after=10800 job-hold-until=no-hold job-priority=50 job-sheets=none,none marker-change-time=1520549755 marker-colors=#000000,#00FFFF,#FF00FF,#FFFF00,none,none,none,none,none,none marker-levels=65,99,18,17,93,75,76,93,69,0 marker-names='Black\ Toner\ S/N\ :CRUM-13080800755,Cyan\ Toner\ S/N\ :CRUM-17042735161,Magenta\ Toner\ S/N\ :CRUM-13080800130,Yellow\ Toner\ S/N\ :CRUM-13080820351,Transfer\ Roller,Transfer\ Belt,Fuser\ Life,Pick-up\ Roller,Imaging\ Unit,Waste\ Toner' marker-types=toner,toner,toner,toner,other,other,fuser,other,other,other number-up=1 printer-commands=none printer-info='Samsung C410 Series' printer-is-accepting-jobs=true printer-is-shared=false printer-is-temporary=false printer-location='family room' printer-make-and-model='Samsung C410 Series' printer-state=3 printer-state-change-time=1520549759 printer-state-reasons=none printer-type=2101324 printer-uri-supported=ipp://localhost/printers/Samsung_C410_Series



Any ideas on what is causing this and how do I correct it?
Do you have an lpoptions file in /etc/cups or $HOME/.cups?

There is no lpoptions file in /etc/cups and the one in $HOME/.cups is empty.