Web lists-archives.com

Re: Problems with clean install of fvwm

On 02/23/2018 09:12 AM, Richard Owlett wrote:
On 02/23/2018 05:46 AM, Richard Owlett wrote:
I run MATE, but to paraphrase a restaurant - "I want Debian MyWay" ;)
It was suggested that I wanted what KDE calls "activities".
It looked promising. I installed it. It suffers from featuritis.
fvwm-crystal was also suggested. When installed it was in some sense "cleaner" but still too busy. Launched fvwm which had been installed by the fvwm-crystal package.

The problem
It had "inherited" configuration items from fvwm-crystal. The web pages I had read spoke of a default 1st run display. I could not figure out how to get that to appear.

Having adequate space available I used netinst to do a base command line only install to a new partition. It was followed by doing "apt-get install fvwm".

I rebooted expecting a minimal fvwm display. I got a command line.

To clarify I got a console command line (Whole screen is one window with no graphical ornaments !)

I found that though a "/home/richard/.fvwm" directory had been created, it was empty. I couldn't find copies of what files should have been there on initial first run. Only instructions/examples for adding this or that doodad.

It was suggested that
So to get you kick-started,
just create a file named "config" in your /home/richard/.fvwm
consisting of this one line:

  Read /usr/share/fvwm/default-config/config
That did not solve my problem.

I copied the file at http://www.einval.com/~steve/debian/fvwm2rc.example to /home/richard/.fvwm2rc  .
I then executed `fvwm2 -f "FvwmM4 .fvwm2rc"'
The result was " [fvwm][main] <<ERROR>> can't open display

Reasoning by analogy with use of startx I had tried "fvwm" at the command line and received "can't open display".

I tried issuing "startx" itself and received "command not found".

When I had initially done "apt-get install fvwm", should some portion of the Xsystem been installed?


I just did "apt-get install xorg".
Now typing "startx" at command line does give me a fvwm screen.
However typing "fvwm" at command line gives
[fvwm][main] <<ERROR>> can't open display

What's still to be installed/configured?
Would this be a bug against the fvwm package for not installing and configuring xorg?