Web lists-archives.com

Re: Debian 9 Image Magick/display xwd(1) format

On 2/22/18, Brian <ad44@xxxxxxxxxxxxxxx> wrote:
> On Thu 22 Feb 2018 at 13:35:20 -0800, John Conover wrote:
>> xwd > myfile
>> display myfile
>> gives:
>>     "display-im6.q16: no decode delegate for this image format `' @
>>     error/constitute.c/ReadImage/504."
>> Anything else read the file and do file conversions?
> xwd > myfile.xwd
> display myfile.xwd
> works here.

I test drove this. It failed twice, and I wrote a response. Then I
decided to try it one more time. It worked.. *that time*..

The first two attempts just sat there spinning their wheels. Never
having done this, I figured it might be like other commands where
you're supposed to keep going while the first is running.

Nope. *grin*

The cursor changed to the crosshair during the first two runs. I
couldn't get into any other program during those moments. I finally
CTRL+C'd to exit.

I thought to verify if anything resembling a file was created.
Something size "0" was sitting there.

Then I ran "xwd > myfile.xwd" a third time, and that's when it worked.
Just ran "display myfile.xwd", and a very nice copy of my top XFCE4
toolbar/panel displayed via Magick..

But it did take 3 tries before it did anything....

PS I just ran it a fourth time... It didn't work again........

PPS I ran it a FIFTH time... and tried clicking another program while
it appeared to be failing again. Computer beeped the sound I've come
to recognize as part of Magick from just having played with Magick
this week..

THEN... I went back to my terminal, and the command had completed its
run. "display" displayed a second very nice resolution'ed copy of the
top toolbar/panel.

*hm* :D

Cindy :)
Cindy-Sue Causey
Talking Rock, Pickens County, Georgia, USA

* runs with duct tape *