Web lists-archives.com

Re: Packages for debian-8.8.0-amd64-netinst.jigdo are missing on fallback mirrors




On Tue, Feb 13, 2018 at 01:38:47PM +0100, Thomas Schmitt wrote:
>Hi,
>
>a thread on debian-user reveils problems with package mirrors for 8.8.0
>jigdo images. It begins at
>  https://lists.debian.org/debian-user/2018/02/msg00531.html
>
>I wrote on debian-user:
>> > "File not found" messages from the user chosen mirror server during
>> > the first pass of jigdo-lite are normal, if the ISO is old. But the
>> > fallback mirror which is given by the .jigdo file should have the
>> > missing ones.
>
>Rick Thomas wrote on debian-user:
>> Out of curiosity, I tried this myself.
>> The commands I used were:
>>
>>    wget https://cdimage.debian.org/cdimage/archive/8.8.0/amd64/jigdo-cd/debian-8.8.0-amd64-netinst.jigdo
>>    wget https://cdimage.debian.org/cdimage/archive/8.8.0/amd64/jigdo-cd/debian-8.8.0-amd64-netinst.template
>>    jigdo-lite debian-8.8.0-amd64-netinst.jigdo
>>
>> Here’s the last screenful of messages from jigdo-lite:
>> ...
>> http://us.cdimage.debian.org/cdimage/snapshot/Debian/dists/jessie/main/installer-amd64/20150422+deb8u4+b3/images/cdrom/initrd.gz
>> Reusing existing connection to us.cdimage.debian.org:80.
>> HTTP request sent, awaiting response... 404 Not Found
>> 2018-02-13 00:23:17 ERROR 404: Not Found.
>> ...
>> Aaargh - 8 files could not be downloaded. [...]
>
>Rick did not show all 8 file URLs. To see are 3 more than the above one:
>
>http://us.cdimage.debian.org/cdimage/snapshot/Debian/dists/jessie/main/installer-amd64/20150422+deb8u4+b3/images/netboot/debian-installer/amd64/grub/x86_64-efi/multiboot.mod
>
>http://us.cdimage.debian.org/cdimage/snapshot/Debian/dists/jessie/main/installer-amd64/20150422+deb8u4+b3/images/netboot/debian-installer/amd64/grub/x86_64-efi/http.mod
>
>http://us.cdimage.debian.org/cdimage/snapshot/Debian/dists/jessie/main/installer-amd64/20150422+deb8u4+b3/images/netboot/debian-installer/amd64/grub/x86_64-efi/multiboot2.mod
>
>This time it does not look like no-matching MD5s but rather like flatly
>missing URLs.
>
>The .jigdo file has as flabback servers:
>  [Servers]
>  Debian=http://snapshot.debian.org/archive/debian/20170506T140911Z/
>  Debian=http://us.cdimage.debian.org/cdimage/snapshot/Debian/ --try-last

It looks like there's been two failures causing files not to be
archived on *both* snapshot.d.o and us.cdimage.d.o. I've just copied
across the missing files onto us.cdimage.d.o now and tested again
successfully with jigdo. I'll file a bug on snapshot.d.o too, to get
things fixed up there.

Thanks for the report!

-- 
Steve McIntyre, Cambridge, UK.                                steve@xxxxxxxxxx
Who needs computer imagery when you've got Brian Blessed?