Web lists-archives.com

Re: Finding older ISOs




On Feb 12, 2018, at 12:47 PM, Thomas Schmitt <scdbackup@xxxxxxx> wrote:

> Hi,
> 
> David Christensen quoted that
> richey goldberg wrote:
>>> That's what I've been using to find the files to plug into jigdo-lite
>>> and I get the file not found errors.
> 
> "File not found" messages from the user chosen mirror server during
> the first pass of jigdo-lite are normal, if the ISO is old. But the
> fallback mirror which is given by the .jigdo file should have the
> missing ones. In case of debian-8.8.0-amd64-DVD-1.jigdo there are two:
>  Debian=http://snapshot.debian.org/archive/debian/20170506T141043Z/
>  Debian=http://us.cdimage.debian.org/cdimage/snapshot/Debian/
> 
> What do you get as final message of the jigdo-lite run ?
> 
> Does the resulting .iso file have the checksum as listed in the
> SHA512SUMS form the directory where you found the .jidgo file ?
> 
> 
> Have a nice day :)
> 
> Thomas
> 

Out of curiosity, I tried this myself.

The commands I used were:

    wget https://cdimage.debian.org/cdimage/archive/8.8.0/amd64/jigdo-cd/debian-8.8.0-amd64-netinst.jigdo
    wget https://cdimage.debian.org/cdimage/archive/8.8.0/amd64/jigdo-cd/debian-8.8.0-amd64-netinst.template
    jigdo-lite debian-8.8.0-amd64-netinst.jigdo

Here’s the last screenful of messages from jigdo-lite:

> --2018-02-13 00:23:16--  http://us.cdimage.debian.org/cdimage/snapshot/Debian/dists/jessie/main/installer-amd64/20150422+deb8u4+b3/images/netboot/debian-installer/amd64/grub/x86_64-efi/multiboot.mod
> Reusing existing connection to us.cdimage.debian.org:80.
> HTTP request sent, awaiting response... 404 Not Found
> 2018-02-13 00:23:16 ERROR 404: Not Found.
> 
> --2018-02-13 00:23:16--  http://us.cdimage.debian.org/cdimage/snapshot/Debian/dists/jessie/main/installer-amd64/20150422+deb8u4+b3/images/netboot/debian-installer/amd64/grub/x86_64-efi/http.mod
> Reusing existing connection to us.cdimage.debian.org:80.
> HTTP request sent, awaiting response... 404 Not Found
> 2018-02-13 00:23:16 ERROR 404: Not Found.
> 
> --2018-02-13 00:23:16--  http://us.cdimage.debian.org/cdimage/snapshot/Debian/dists/jessie/main/installer-amd64/20150422+deb8u4+b3/images/netboot/debian-installer/amd64/grub/x86_64-efi/multiboot2.mod
> Reusing existing connection to us.cdimage.debian.org:80.
> HTTP request sent, awaiting response... 404 Not Found
> 2018-02-13 00:23:17 ERROR 404: Not Found.
> 
> --2018-02-13 00:23:17--  http://us.cdimage.debian.org/cdimage/snapshot/Debian/dists/jessie/main/installer-amd64/20150422+deb8u4+b3/images/cdrom/initrd.gz
> Reusing existing connection to us.cdimage.debian.org:80.
> HTTP request sent, awaiting response... 404 Not Found
> 2018-02-13 00:23:17 ERROR 404: Not Found.
> 
> Skipping object `debian-8.8.0-amd64-netinst.iso.tmpdir' (No such file or directory)
> Found 0 of the 8 files required by the template
> Copied input files to temporary file `debian-8.8.0-amd64-netinst.iso.tmp' - repeat command and supply more files to continue
> 
> -----------------------------------------------------------------
> Aaargh - 8 files could not be downloaded. This should not
> happen! Depending on the problem, it may help to retry downloading
> the missing files.
> Also, you could try changing to another Debian or Non-US server,
> in case the one you used is out of sync.
> 
> However, if all the files downloaded without errors and you
> still get this message, it means that the files changed on the
> server, so the image cannot be generated.
> As a last resort, you could try to complete the CD image download
> by fetching the remaining data with rsync.
> 
> Press Return to retry downloading the missing files.
> Press Ctrl-C to abort. (If you re-run jigdo-lite later, it will
> resume from here, the downloaded data is not lost if you press
> Ctrl-C now.)
> : ^C
> 

So where did the missing files go?

Rick