Web lists-archives.com

Re: Debian buster & gnucash




On 02/08/2018 12:25 PM, Donald F. Emery wrote:
> I am new to debian and was hoping someone could tell me why
> GNUCASH was not in debian testing.
> 

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=790204

The bug report explains the current status of gnucash in testing.

I installed gnucash from unstable by adding this line

deb http://deb.debian.org/debian sid main

(temporarily) to /etc/apt/sources.list, then running

# apt update

then

# apt install gnucash*

Following that I commented out the testing line in
/etc/apt/sources.list and ran

# apt update

again to get the apt package database back to its normal
contents for testing.

Normally when using unstable like this I would alter the apt
configuration to give preference to the version in unstable and
/ or pin the version of the package I want, but since there is
no version of gnucash and gnucash-docs available in testing, I
just got lazy and did nothing about that. Currently these
instructions should get you version 1:2.6.18-1 of gnucash. It's
working well for me.

I hope one of the sharper-eyed and less lazy of the list members
will give you better instructions if warranted.

As I understand it, the version in experimental is not yet a
good choice for someone who needs a properly functioning
installation of the package.

HTH,
JP