Web lists-archives.com

Re: Ethernet is not started at boot




On 07.02.18 09:33, Michelle Konzack wrote:
> Good morning,
> 
> Am 2018-02-07 hackte Gene Heskett in die Tasten:
> > On Tuesday 06 February 2018 14:07:55 Brian wrote:
> >> 1. auto enp0s25
> >>                                                  iface enp0s25 inet
> >> static address         192.168.0.202
> >>         netmask         255.255.255.0
> >>         gateway         192.168.0.1
> >>         network         192.168.0.0
> >>
> >> netmask and network are not needed. ifupdown will compute them. Note
> >> there are no examples in interfaces(5) which use these parameters.
> >>
> > You should go and read that man page again.
> 
> Who do you mean?
> 
> I have als a network with
> 
> auto eth2
> iface eth2 inet static
>         address         192.168.4.12
>         netmask         255.255.127.0
>         gateway         192.168.4.1
>         network         192.168.4.0
> 
> So, it is not so good idea to leafe it out

Michelle, that netmask is 0b11111111111111111000000100000000 , which is
the first I have ever seen with a hole in it. For 512 addresses, I'd
have expected 255.255.254.0, which has contiguous bits:
0b11111111111111111111111000000000 (If 10 bits (1024 addresses) were the
aim, then it would be 252, but never 127, if I have any kind of grip on
this stuff.)

Not trusting the software to handle an unusual netmask, I might have
been tempted to just use a class B netmask, 255.255.0.0 , but then I can
be a Feigling in such matters.

Erik