Web lists-archives.com

Re: Package pinning on origin AND version




On 2018-02-06 at 07:52, Adam Cecile wrote:

> On 02/06/2018 01:46 PM, The Wanderer wrote:
>
>> Pin: version 1.3.*, release o=packages.le-vert.net
> 
> Hello,
> 
> Thanks for the answer, sadly it's not working:
> 
> mesos:
>    Installed: 1.3.1-1+Debian-stretch-9.1
>    Candidate: 1.4.1-1+Debian-stretch-9.1

Not sure what may be causing that. Just as a stab in the dark, maybe try
it with 'Pin-Priority: 1001', in case something else is setting the
priority of the 1.4.x version to 1000? (Again per 'man apt_preferences',
when two versions have equal priority, the higher version number wins
out.)

Note that a priority greater than 1000 will lead the matching version to
be considered even when it would be a version-number downgrade from the
installed version. That may be what you want (it often is, for me), but
it's something that's good to be aware of.

-- 
   The Wanderer

The reasonable man adapts himself to the world; the unreasonable one
persists in trying to adapt the world to himself. Therefore all
progress depends on the unreasonable man.         -- George Bernard Shaw

Attachment: signature.asc
Description: OpenPGP digital signature