Web lists-archives.com

Re: Package pinning on origin AND version




On 2018-02-06 at 03:01, Adam Cecile wrote:

> Hello,
> 
> I'd like to do something like this:
> 
> Package: mesos
> Pin: version 1.3.*
> Pin: release o=packages.le-vert.net
> Pin-Priority: 1000
> 
> But sadly the last "Pin:" line overrides the previous one.

Try:

Package: mesos
Pin: version 1.3.*, release o=packages.le-vert.net
Pin-Priority: 1000

This is documented in 'man apt_preferences', at the end of the section
"The Effect of APT Preferences"; the comma in a Pin: line functions as
an "and" operator. (There's a caveat mentioned there, but it shouldn't
apply in your case.)

-- 
   The Wanderer

The reasonable man adapts himself to the world; the unreasonable one
persists in trying to adapt the world to himself. Therefore all
progress depends on the unreasonable man.         -- George Bernard Shaw

Attachment: signature.asc
Description: OpenPGP digital signature