Web lists-archives.com

Re: Kernel for Spectre and Meltdown




On Mon, 29 Jan 2018 10:47:57 -0500
rhkramer@xxxxxxxxx wrote:

> Again, checking / confirming my understanding, if you download a kernel
> image (which is normal for me), there is no need for me to have any
> version of GCC as the image is pre-compiled.

Sure.

> 
> On the other hand, if I download kernel source, I would need GCC, and a 
> version that is sufficient for the code.

That is point here, at least as far as I understood for that new "spectre
fix" one needs a compiler that is "retpoline-aware" (as the
"checker"-script calls it, whatever that means) and currently this is only
true for gcc >= 7.3. So if you compile the kernel on Stretch with gcc-6
this "retpoline" fix will not work.

Regards

Michael


.-.. .. ...- .   .-.. --- -. --.   .- -. -..   .--. .-. --- ... .--. . .-.

Earth -- mother of the most beautiful women in the universe.
		-- Apollo, "Who Mourns for Adonais?" stardate 3468.1