Web lists-archives.com

Re: Kernel for Spectre and Meltdown




On Mon, Jan 29, 2018 at 08:35:58AM +0000, Michael Fothergill wrote:
​Your need to upgrade to unstable (Debian Sid).  Then you need to get the
latest kernel from the kernel.org website.

This is not good advice to a beginner.

You also need to install GCC7 in sid which will give you version 7.3.0 at
present.  That is a new enough compiler to be able to properly install the
spectre and meltdown fixes.
Then you need to run the spectre/meltdown checker which you can get from a
github site and run locally on your box to know it's really installed
properly.

spectre-meltdown-checker is packaged (in sid), this is a better route to
get the script as it is (or will be) adjusted to work properly on a
Debian system.

--

⢀⣴⠾⠻⢶⣦⠀
⣾⠁⢠⠒⠀⣿⡁ Jonathan Dowland
⢿⡄⠘⠷⠚⠋⠀ https://jmtd.net
⠈⠳⣄⠀⠀⠀⠀ Please do not CC me, I am subscribed to the list.