Web lists-archives.com

Re: Why was this package removed but apt?




-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On Wed, Jan 10, 2018 at 12:01:50PM +0100, Jonathan Sélea wrote:
> Hi
> 
> I am running Debian Stretch but with sury.org repository. :)
> 
> Jonathan Download suggested that I checked what package is depending php7.1-mbstring  on with:
> 
> apt rdepends php7.1-mbstring
> 
> php7.1-mbstring
> 
> Reverse Depends:
>   Depends:
> 
> php7.1-mbstring-dbgsym (= 7.1.13-1+0~20180105151623.14+stretch~1.gbp1086fa)
> 
> That particular package was not installed thou.

Then things depend (heh, pun :) on how the upgrade was made. If that package
doesn't depend on anything and it was automatically installed, it may well
be (depending on configuration, somewhere in /etc/apt) that it gets automatically
removed when not needed anymore. The question is... why was it installed in
the first place?

Perhaps you find a hint somewhere in /var/log/apt/term.log

Cheers
- -- tomás
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)

iEYEARECAAYFAlpV9n4ACgkQBcgs9XrR2kbP+QCeMVzcvSTgnUAlhZoMeX45t7oq
NPoAnA3XSZ4r/6N22EhneAaKZRdwjBvP
=IVds
-----END PGP SIGNATURE-----