Web lists-archives.com

Re: Why was this package removed but apt?




Hi

I am running Debian Stretch but with sury.org repository. :)

Jonathan Download suggested that I checked what package is depending php7.1-mbstring  on with:

apt rdepends php7.1-mbstring

php7.1-mbstring

Reverse Depends:
  Depends:

php7.1-mbstring-dbgsym (= 7.1.13-1+0~20180105151623.14+stretch~1.gbp1086fa)

That particular package was not installed thou.

/ Jonathan




On 01/10/2018 11:41 AM, tomas@xxxxxxxxxx wrote:
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On Wed, Jan 10, 2018 at 11:17:50AM +0100, Jonathan Sélea wrote:
Good morning,

I am trying to figure out why apt did remove this particular package
when unattended-upgrade ran a couple of days ago:


Start-Date: 2018-01-06 06:43:44
Commandline: /usr/bin/unattended-upgrade Remove:
php7.1-mbstring:amd64
Hum: which distro are you running? I'm asking this, because...

(7.1.13-1+0~20180105151623.14+stretch~1.gbp1086fa)
End-Date: 2018-01-06 06:43:50
...I read "stretch" above, but stretch "only" has php7.0-mbstring
(7.1 is in buster(testing) or sid(unstable) but not on stretch).

So my crystal ball says you're using a backport or a non-official
repository. This isn't an infraction per se (free software is made
to hack on, after all :-) but stating that might help debugging
things.

Cheers
- -- tomás
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)

iEYEARECAAYFAlpV7dcACgkQBcgs9XrR2kbWlACeOjKCcObd80EpwBXmvUy0/UK8
HIIAnAzeVaWmdWmkY+NIwL3pIqQ/kQWd
=KdCF
-----END PGP SIGNATURE-----



Attachment: smime.p7s
Description: S/MIME Cryptographic Signature