Web lists-archives.com

Re: old Wheezy will not upgrade linux-kernel




On Mon, Jan 08, 2018 at 06:38:16AM +0000, Bonno Bloksma wrote:
> Hi,
> 
> Running al old wheezy system that is up-2-date on patches but....
> 
> I am running the v3.2.x kernel 
> # uname -a
> Linux linbobo.... 3.2.0-4-686-pae #1 SMP Debian 3.2.96-2 i686 GNU/Linux
> 
> After apt-get update I do an upgrade and it seems the kernel package will not install but is held back
> [....]
> # apt-get upgrade -V
> The following packages have been kept back:
>    linux-image-686-pae (3.2+46 => 3.2+46+deb7u1)
> 
>From apt-get(1):

       upgrade
           upgrade is used to install the newest versions of all packages currently installed on the
           system from the sources enumerated in /etc/apt/sources.list. Packages currently installed
           with new versions available are retrieved and upgraded; under no circumstances are
           currently installed packages removed, or packages not already installed retrieved and
           installed. New versions of currently installed packages that cannot be upgraded without
           changing the install status of another package will be left at their current version. An
           update must be performed first so that apt-get knows that new versions of packages are
           available.

> Doing a manual install it seems the v3.2.0-4 kernel needs to be upgraded to a v3.2.0.-5 kernel. 
> 
> # apt-get install linux-image-686-pae
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> The following extra packages will be installed:
>   linux-image-3.2.0-5-686-pae
> Suggested packages:
>   linux-doc-3.2 debian-kernel-handbook
> The following NEW packages will be installed:
>   linux-image-3.2.0-5-686-pae
> The following packages will be upgraded:
>   linux-image-686-pae
> 1 upgraded, 1 newly installed, 0 to remove and 6 not upgraded.
> Need to get 23.0 MB of archives.
> After this operation, 80.0 MB of additional disk space will be used.
> Do you want to continue [Y/n]?
> 
> Should that then not simply be a upgrade?
> Is there any reason not to just simply do the apt-get install ?
> 
> I have this "problem" on at least 2 Wheezy machines.  One I cannot upgrade to Lenny. Which is the reason I have at least one other (not critical) machine also at Wheezy so I can compare and test.
> 

The reason that you are encountering this issue is because the changes
to the kernel necessitated an ABI change.  The Linux kernel package name
includes the ABI version to allow you to have multiple versions of the
same kernel with different ABIs.  Plus, it makes it easy to boot back
into the previous version with any custom built modules (e.g., through
DKMS) that may not work or be built for the new kernel ABI.

I recommend that you use dist-upgrade (which will pull in new packages)
or use the install command as you found that also works.

Regards,

-Roberto

-- 
Roberto C. Sánchez