Web lists-archives.com

Re: After upgrade jessie -> stretch : php problems




Hello,

first of all check the installed / activate modules in you php
environment. that means and "php -i" on cli can have other results than
run phpinfo() via browser / apache2 or fastcgi if used.

Are the relevant modules active ?
Have you try to reload / restart your http / (fastcgi if used) server?

I had also trouble with php 5.6 and php 7.0 modules installed at same
time but don't know the details anymore.

can you connect to your mysql server via cli?
I remember that a php site show error "missmatch module version" but
there where a permission problem while connection to db.

Best regards,
Basti


On 04.01.2018 16:16, Markus Grunwald wrote:
> Hello,
> 
> Today I tackled the upgrade from jessie to stretch on my "production"
> server (hosts a few websites).
> 
> Almost all went smoothly, but a few problems remain. One is this: The
> cron job of my owncloud installation reports this:
> 
> ---------------------------------------------------------------------
> No database drivers (sqlite, mysql, or postgresql) installed.
> 
> 
> PHP is configured to populate raw post data. Since PHP 5.6 this will
> lead to PHP throwing notices for perfectly valid code.
> To fix this issue set <code>always_populate_raw_post_data</code> to
> <code>-1</code> in your php.ini
> 
> PHP modules have been installed, but they are still listed as missing?
> Please ask your server administrator to restart the web server.
> ---------------------------------------------------------------------
> 
> I have absolutely no clue about php and surely didn't touch any of these
> packages (besides installing them because I need them for owncloud and
> drupal).
> 
> I have searched /etc for all php.ini files and changed
> always_populate_raw_post_data as requested, without success.
> 
> php modules for mysql are installed.
> 
> Now I have no idea what is still wrong, because I still get the error
> messages (as mail from the cronjob which floods my mail :( )
> 
> Maybe of interest: that's part of the phpinfo() output:
> 
> PHP Version			5.6.30-0+deb8u1
> Directive			Local Value	Master Value
> allow_url_fopen			On	On
> allow_url_include		Off	Off
> always_populate_raw_post_data	-1	-1
> 
> 
> Installed packages regarding php: as textfile in the attachments to keep
> the formatting...
> 
> I would be very glad, if you could help me.
> Also, please have a look at my other problem with munin (doh)
> 
> cu
>