Web lists-archives.com

Re: lm-sensors doesn't see the cpu rpm.....






On 28 December 2017 at 13:55, Greg Wooledge <wooledg@xxxxxxxxxxx> wrote:
On Thu, Dec 28, 2017 at 01:11:56PM +0000, Michael Fothergill wrote:
> root@bong:/boot#  sudo modprobe coretemp
> modprobe: ERROR: could not insert 'coretemp': No such device
>
>
> This is odd because coretemp is set as a module option in the config file:
>
> CONFIG_SENSORS_CORETEMP=m
>
> Comments appreciared

Well, it *should* work with a standard Debian kernel and applicable
hardware.

​Dear All,

It's sad but I think I need install Windows 10 on this machine to sort out the fan control and cpu cooler problems.

This machine overheats when I run pov-ray benchmark on it and shuts down.

Then I can install the ASUS Fan Xpert and ROG software etc on top of the FX 990 sabertooth motherboard I have.......

I think I might need to change the thermal paste compound between the CPU and Arctic Freezer 13 heatsink to cure the cooling problem.

I am going to use Artic MX-4 paste.

While Debian and Gentoo are OK to work with here, I cannot tolerate the machine shutting down now and again due to overheating any longer.

I am corresponding with the ASUS technical folks at present.

I need the extra special bloodhound Passau Cathedral Organ factor here to help check on the temps and the fan activity once I start doing
surgery on the cpu/fan-heatsink thermal interface...........

CPUs cost money.

Thanks for the help to date.

Regards

MF

 

 

wooledg:~$ /sbin/modinfo coretemp
filename:       /lib/modules/4.9.0-4-amd64/kernel/drivers/hwmon/coretemp.ko
license:        GPL
description:    Intel Core temperature monitor
author:         Rudolf Marek <r.marek@xxxxxxxxxxxx>
alias:          cpu:type:x86,ven0000fam*mod*:feature:*01C0*
depends:
intree:         Y
vermagic:       4.9.0-4-amd64 SMP mod_unload modversions
parm:           tjmax:TjMax value in degrees Celsius (int)

Your "No such device" error sounds like it probed for hardware and didn't
find any.  If the module itself were missing from the file system, then
I would have expected "FATAL: Module coretemp not found in directory ...".

It says "Intel" in the description.  Are you using an Intel CPU?