Web lists-archives.com

Re: need a video function in wheezy




On Thu, Nov 16, 2017 at 09:21:33PM -0500, Gene Heskett wrote:
> Greetings all;
> 
> I have a machine vision utility for use on a CNC machine, that uses 
> gladevcp.
> 
> But the launching script, in xml, is looking for a specific lib:
> 
>  <requires lib="gtk+" version="2.24"/>
> 
> which if it ever did exist in wheezy, was since removed.
> 
> This script is of course editable, so are the functions that were in this 
> lib, now available in a different package? If so, likely suspects 
> please?
> 
Hi Gene,

I suspect that your tool was built with the naming conventions used by
Red Hat in mind.  You probably need to change lib="gtk+" to
lib="gtk+2.0".  Here is the link to the source package in wheezy:

https://packages.debian.org/source/wheezy/gtk+2.0

Another possible candidate would be lib="libgtk2.0-0" for the name of
the actual binary package.

Regards,

-Roberto

-- 
Roberto C. Sánchez