Web lists-archives.com

Re: Missing qt5-designer in Stretch




On 11/14/2017 12:18 AM, Christian Seiler wrote:
Am 2017-11-14 08:05, schrieb Marc Shapiro:
Am I missing something, somewhere?  Or is qt5-designer not packaged for Debian?

Designer for Qt5 can be found in the qttools5-dev-tools package
in Stretch.

Regards,
Christian

I installed qttools5-dev-tools package, but it still looks for designer and assistant in the old qt4 directory.  What am I doing wrong?

Marc


$ aptitude show qttools5-dev-tools
Package: qttools5-dev-tools
Version: 5.7.1-1
New: yes
State: installed
Automatically installed: no
Multi-Arch: same
Priority: optional
Section: devel
Maintainer: Debian Qt/KDE Maintainers <debian-qt-kde@xxxxxxxxxxxxxxxx>
Architecture: amd64
Uncompressed Size: 7,367 k
Depends: qtchooser, libc6 (>= 2.14), libqt5core5a (>= 5.7.0), libqt5dbus5 (>= 5.0.2), libqt5designer5 (>= 5.6.0~beta), libqt5designercomponents5 (>= 5.6.0~beta), libqt5gui5 (>= 5.7.0), libqt5help5 (>= 5.6.0~beta), libqt5network5 (>=          5.0.2), libqt5printsupport5 (>= 5.0.2), libqt5quickwidgets5 (>= 5.3.0), libqt5sql5 (>= 5.0.2), libqt5webkit5 (>= 5.6.0~rc), libqt5widgets5 (>= 5.6.0~beta), libqt5xml5 (>= 5.1.0), libstdc++6 (>= 5.2), qtbase-abi-5-7-1
Recommends: libqt5sql5-sqlite
Breaks: qtbase5-dev-tools (< 5.6.0~), qttools5-dev (< 5.5.0-2~), qtbase5-dev-tools:i386 (< 5.6.0~), qttools5-dev:i386 (< 5.5.0-2~), qttools5-dev-tools:i386 (!= 5.7.1-1) Replaces: qtbase5-dev-tools (< 5.6.0~), qttools5-dev (< 5.5.0-2~), qtbase5-dev-tools:i386 (< 5.6.0~), qttools5-dev:i386 (< 5.5.0-2~), qttools5-dev-tools:i386 (< 5.7.1-1)
Description: Qt 5 development tools
 Qt is a cross-platform C++ application framework. Qt's primary feature is its rich set of widgets that provide standard GUI functionality.

 This package contains a set of applications to browse the documentation, translate applications, generate help files and other stuff that helps in Qt development. These tools are among others:
 * assistant
 * designer
 * linguist
 * pixeltool
 * qdbusviewer
Homepage: https://www.qt.io/developers/
Tags: uitoolkit::qt

$ designer
designer: could not exec '/usr/lib/x86_64-linux-gnu/qt4/bin/designer': No such file or directory
$ assistant
assistant: could not exec '/usr/lib/x86_64-linux-gnu/qt4/bin/assistant': No such file or directory