Web lists-archives.com

KVM PCI Passthrough NVidia GeForce GTX 1080 Ti error code 43




Dear all,

Please help me passthrough my GPU the a KVM guest.

The system I am using:
lshw: https://pastebin.com/tB7FqqxN

Host OS:Debian 9 Stretch
Mainboard: Supermicro C7Z170-M (activated VT-d in Bios)
CPU: Intel Core i7-7700K CPU @ 4.20GHz
GPU: EVGA GeForce GTX1080 Ti

The GPU is not listed because I have blacklisted it:
    $ cat /etc/modprobe.d/blacklist.conf 
    blacklist nouveau

lspci: https://pastebin.com/6qYuJRPg

I found this guide:
https://scottlinux.com/2016/08/28/gpu-passthrough-with-kvm-and-debian-linux/

After installing Win7 guest, enabling PCI passthrough using
virt-manager, installing the NVidia driver in the guest, Windows reports
the error 43 for the GPU.

Windows has stopped this device because it has reported problems.
(Code 43)

This is described in the above mentioned post and a workaround is
linked:
https://www.reddit.com/r/VFIO/comments/479xnx/guests_with_nvidia_gpus_can_enable_hyperv/

Unfortunately I do not know how to apply the workaround. I understand
that I should create a file '/usr/libexec/qemu-kvm-hv-vendor' with the
following content:

    #!/bin/sh
    exec /usr/bin/qemu-kvm \
    `echo "\$@" | sed 's|hv_time|hv_time,hv_vendor_id=whatever|g'`

Or according to the original redhat mailing list post by Alex
Williamson:
https://www.redhat.com/archives/vfio-users/2016-March/msg00092.html

    $ cat /usr/libexec/qemu-kvm-hv-vendor 
    #!/bin/sh
    exec /usr/bin/qemu-kvm \
	`echo "\$@" | sed 's|hv_time|hv_time,hv_vendor_id=KeenlyKVM|g'`

But since there is no qemu-kvm present and the directory '/usr/libexec'
does not exist on my system, I wonder how I should proceed.

Any help fixing my problem would be highly appreciated.


Thanky you very much in advance and best regards,
Ramon