Web lists-archives.com

Re: Seems i broke my debian :c help me please




-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On Thu, Nov 09, 2017 at 05:42:39PM +0600, Evgeny wrote:
> Hello all. I've just change switched my debian from jessie to testing and
> done
> 
> apt-get update
> apt-get dist-upgrade
> 
> And while packages were installing free space ended.
> Now when I try to use apt-get i have an error:
> 
> E: Unable to parse package file /var/lib/apt/extended_states (1)
> 
> when I try "apt --fix-broken install" i have
> 
> E: Unable to correct problems, you have held broken packages.
> E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused
> by held packages.
> E: Unable to correct dependencies
> 
> may be I can find something in /var/log/apt/term.log by some keywords?
> because it is really big
> 
> is there a way to fix it? or it's easier to reinstall (not the best way out
> for me)?

There are backups of it (by default 7) in /var/backups/apt.extended_states*,
the most recent of which is apt.extended_states.0 (uncompressed), the others
.1.gz and so on are gzipped.

Since the thing seems to have been broken while writing to extended_state
chances are good that the newest backup, .0, is a good substitute for
the current file.

Good luck and... take backups :)

Cheers
- -- tomás
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)

iEYEARECAAYFAloEQroACgkQBcgs9XrR2kYx/ACeLhyp4SC9tPPpR6Dlpm4XJq+p
Cs4An1BDBoSMewG2SK+b7tAgjNTQU3JV
=AQbz
-----END PGP SIGNATURE-----