Web lists-archives.com

Re: mount.cifs not working anymore




Le 11/07/17 à 18:22, Joe a écrit :
> On Tue, 7 Nov 2017 17:57:06 +0100
> Erwan David <erwan@xxxxxxxxxxx> wrote:
>
>> I am not sure I tested it since I upgraded from Jessie to stretch :
>>
>> I have the following entry in my fstab
>>
>> //mafreebox.freebox.fr/Disque\040Dur /mnt/Fbx cifs 
>> noauto,users,rw,credentials=/etc/fbx-passwd,uid=erdavid      
>> 0               0
>>
>> It used to work, now it says :
>>
>> @bibi:~ % mount /mnt/Fbx
>> mount error(112): Host is down
>> Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
>>
>> Using smb:// in dolphin works, so the smb server is still working.
>> What can be the reason ?
>>
> I believe it is a matter of SMB protocol, modern versions of samba
> refusing to use the insecure protocol 1 unless kicked hard. You can
> force it to do so, with vers=1.0 as an option in /etc/fstab, though you
> should probably switch your samba shares to a later protocol. It was
> SMB1.0 which wannacry exploited.
>
> If they're still on wheezy (samba 2.3) this is not possible, it cannot
> use protocol 2.0 or later. I'm preparing to upgrade a wheezy server, so
> I'm in the position of trying to get a very mixed network to still see
> samba 2.3 while being ready for jessie, then stretch servers with
> minimal mucking about. A real can o' worms...
>

Thanks it was the solution. The server is the box which connects to my
ISP and where the incorporated PVR stores its files.

Only thing to do will be to open a bugreport to them for adding smb 2
support.


Thanks for the help.