Web lists-archives.com

Re: Bug: updating Debian9 not "allowed".




On Thu, Oct 26, 2017 at 11:50:05AM +0000, Joerg Desch wrote:
I'm still running Debian 8 on all of my systems. Since it is time to
switch to Debian 9, I've tried to have a first look at it. So I've
installed the nonfree DVD-Image 9.2 within a VirtualBox container. All
went fine, until I've tried to update the APT database.

Both, apt and Synaptics updates fails. In both cases the error reports,
that /etc/apt/trusted.gpg is not accessible by user "_apt".

The recommendation I've found was to delete trusted.gpg.

OK, this was a workaround for using apt. Both update and upgrade works
without errors. Trying Synaptics leads to the previous behavior. The file
trusted.gpg appears again and with this file, the error returns.

[Aside: The debian packaging tool is called "synaptic". "Synaptics" are a company producing touchpads. The two are not related]

I believe this is a known bug in synaptic: #864640 [1].


[1] https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=864640



By the way... Why is the VirtualBox Guest Utils package not available in
the official repositories?

It is: https://packages.debian.org/search?keywords=virtualbox-guest-utils




--
For more information, please reread.

Attachment: signature.asc
Description: PGP signature