Web lists-archives.com

Re: x : keyboard not working




-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On Fri, Oct 06, 2017 at 09:16:36PM +0530, Mayuresh Kathe wrote:
> On Fri, Oct 06, 2017 at 05:02:45PM +0200, tomas@xxxxxxxxxx wrote:
> > On Fri, Oct 06, 2017 at 08:22:41PM +0530, Mayuresh Kathe wrote:
> > 
> > [X keyboard not working]
> > 
> > This depends on a couple of things. E.g. is your X using X input?
> > If yes, it's supposed to work automagically. If not, you might need
> > to put a stanza in your /etc/X11/xorg.conf which looks more or less
> > like
> > 
> >   Section "InputDevice"
> >     Identifier "the-keyboard"
> >     Driver "kbd"
> >     Option "XkbModel" "pc104"
> >   EndSection
> > 
> > or something similar.
> > 
> > Could you post your X server's log? Where is it located?
> > (the two possibilities know to me are ~/.local/share/xorg/
> > and /var/log/Xorg.0.log, depending on whether your X server
> > runs rootless or not).
> 
> sure, your stanza for /etc/X11/xorg.conf didn't work, it just
> refused to startup the X server itself.
> actually, that file itself did not exist at that location, i
> had to create it, and when it didn't work, i deleted it, and
> the same old stuff was on again, i.e. X worked, but keyboard
> didn't.
> please find below my X server's log;
> 
> [   533.054] 
> X.Org X Server 1.19.2
> Release Date: 2017-03-02

[...]

> [   533.156] (==) ModulePath set to "/usr/lib/xorg/modules"
> [   533.156] (II) The server relies on udev to provide the list of input devices.
> 	If no devices become available, reconfigure udev or disable AutoAddDevices.

[...]

> [   535.260] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event0)
> [   535.260] (II) No input driver specified, ignoring this device.
> [   535.260] (II) This device may have been added with another device file.

The above looks like a smoking gun to me...

> [   535.261] (II) config/udev: Adding input device ETPS/2 Elantech Touchpad (/dev/input/event1)
> [   535.261] (**) ETPS/2 Elantech Touchpad: Applying InputClass "touchpad catchall"
> [   535.261] (**) ETPS/2 Elantech Touchpad: Applying InputClass "Default clickpad buttons"
> [   535.261] (II) LoadModule: "synaptics"
> [   535.261] (II) Loading /usr/lib/xorg/modules/input/synaptics_drv.so
> [   535.306] (II) Module synaptics: vendor="X.Org Foundation"

...while this (and following) shows your touchpad happily chattering.

Note that there's no other mention of keyboard in the log file.

I must run now, so I'll leave it at that here. Perhaps someone else can pick up.

Cheers
- -- t
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)

iEYEARECAAYFAlnXruAACgkQBcgs9XrR2ka6VwCeKZ8SxAK0aRySVM0lSnOSvKD8
RHQAn2ONdmcWqveuXKvjmTMnbjfpUj+3
=PLDo
-----END PGP SIGNATURE-----